WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 3 months ago

#40583 closed defect (bug) (fixed)

TinyMCE Paste Plugin Copy Paste Issue

Reported by: swsdreams19 Owned by:
Milestone: Priority: normal
Severity: critical Version: 4.7.4
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I am using Annotum theme and for some reason tinyMCE editor doesn't allow me to paste content in custom post type.
Here is the error:

tinymce.min.js?ver=4506-20170408:12 Uncaught TypeError: n.$.contains is not a function

at L.focus (tinymce.min.js?ver=4506-20170408:12)
at Object.m [as execCommand] (tinymce.min.js?ver=4506-20170408:8)
at L.execCommand (tinymce.min.js?ver=4506-20170408:12)
at L.insertContent (tinymce.min.js?ver=4506-20170408:12)
at s (plugin.min.js?wp-mce-4506-20170408:1)
at Array.<anonymous> (plugin.min.js?wp-mce-4506-20170408:1)
at Object.n [as each] (tinymce.min.js?ver=4506-20170408:3)
at l (plugin.min.js?wp-mce-4506-20170408:1)
at Object.u [as insertContent] (plugin.min.js?wp-mce-4506-20170408:1)
at s (plugin.min.js?wp-mce-4506-20170408:1)

If this is theme error just let me know, I see js links to wp-includes/js/ folder.

Change History (6)

#1 follow-ups: @azaozz
2 years ago

  • Keywords reporter-feedback added

Hi @swsdreams19, looks like you're not running in production or have prevented script concatenation. In this case the above is possibly a (simple) caching problem. Please clear the browser cache, then reload the page couple of times while holding Shift.

Alternatively enable SCRIPT_DEBUG and try to reproduce. That will force the loading of non-minified TinyMCE plugins (JS) from the server.

If that still happens, please paste the errors from the console while SCRIPT_DEBUG is enabled. That may give more clues to where the problem comes from.

Last edited 2 years ago by azaozz (previous) (diff)

#2 in reply to: ↑ 1 @swsdreams19
2 years ago

Replying to azaozz:
Thank you for the reply, forgive me I did not get you on "running in production or have prevented script concatenation" I have enabled SCRIPT_DEBUG but nothing changes. I have countless times cleared cache and used incognito mode and the error is same.

The issue arises in custom post type of the theme attached image when I try to paste content from web or word
http://devserver.swsdreams.com/client/annotum/tinyMCE-issue.png

Please advise. Thank you for looking into this.

Hi @swsdreams19, looks like you're not running in production or have prevented script concatenation. In this case the above is possibly a (simple) caching problem. Please clear the browser cache, then reload the page couple of times while holding Shift.

Alternatively enable SCRIPT_DEBUG and try to reproduce. That will force the loading of non-minified TinyMCE plugins (JS) from the server.

If that still happens, please paste the errors from the console while SCRIPT_DEBUG is enabled. That may give more clues to where the problem comes from.

#3 @swsdreams19
2 years ago

  • Keywords reporter-feedback removed

#4 in reply to: ↑ 1 @swsdreams19
2 years ago

  • Severity changed from normal to critical

The error is same on all browsers too - firefox

L.prototype.focus http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:12:2213

m http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:8:10431
L.prototype.execCommand http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:12:4473
L.prototype.insertContent http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:12:7198
pasteHtml http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:303:3
smartInsertContent/< http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:317:11
n http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:3:1531
smartInsertContent http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:312:3
insertContent http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:325:4
pasteHtml http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:408:6
pasteText http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:448:4
insertClipboardContent http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:877:6
registerEventHandlers/</< http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/plugins/paste/plugin.js:931:7
.setEditorTimeout/< http://devserver.swsdreams.com/client/annotum/wp-includes/js/tinymce/tinymce.min.js:2:9374


Replying to azaozz:

Hi @swsdreams19, looks like you're not running in production or have prevented script concatenation. In this case the above is possibly a (simple) caching problem. Please clear the browser cache, then reload the page couple of times while holding Shift.

Alternatively enable SCRIPT_DEBUG and try to reproduce. That will force the loading of non-minified TinyMCE plugins (JS) from the server.

If that still happens, please paste the errors from the console while SCRIPT_DEBUG is enabled. That may give more clues to where the problem comes from.

#5 @webstarters
2 years ago

Works for me, after latest update on wordpress. Haven't worked in along time

Thanks!

Last edited 2 years ago by ocean90 (previous) (diff)

#6 @azaozz
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

This appears to have been fixed some time ago. Feel free to reopen if it still needs fixing in the classic editor.

Note: See TracTickets for help on using tickets.