WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 3 months ago

#40994 reopened defect (bug)

Latest update broke full justification

Reported by: seasoned_geek Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Editor Keywords:
Focuses: Cc:

Description

I just applied the latest WordPress update (4.8.x I believe) and full justification of text has been broken. I used to be able to hand edit in the tag, but now it is just ignored.

Change History (7)

#1 @dd32
4 years ago

  • Keywords reporter-feedback added

Hi @seasoned_geek and welcome to Trac.

Are you able to provide a bit more information about what you're actually seeing?

I've added some text and wrapping it in <div style="text-align: justify;"> and that seems to be respected when viewing a post. The editor doesn't strip it out either.

Can you post the exact steps you use which appear to be ignored?

#2 @pento
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket, as we're unable to reproduce this issue without more information.

#3 @seasoned_geek
2 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I never got the request for more information. The paragraph level justification broke. I wrote a post years ago about it.

http://www.interestingauthors.com/blog/thankyousirmayihaveanother/getting-justification-and-underscore-in-wordpress/

Both the editor and the site used to respect that.

Been having to hack around it with Additional CSS of

p{
    
    text-align: justify;
}

p.custom-indent { 
    text-align: justify;
text-indent:25px;
} 

#4 @sabernhardt
5 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I'll re-close this ticket for a few reasons:

  1. If you want full justification, setting the style in Additional CSS is a better method so that it's consistent.
  2. A plugin can restore the justify button to the Classic editor toolbar if you want the style only on certain individual elements.
  3. Editing the HTML to <p style="text-align: justify;"> still works.
  4. The example post uses <p align="justify">, which is no longer valid HTML.
  5. Please reconsider using full justification because it can be more difficult to read than left-aligned text (in English), especially on narrower screens. (See ticket:39244#comment:1 for reasons why the toolbar button was purposely removed.)

#5 @seasoned_geek
5 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'll re-open this bug for the following reasons:

  1. The hack of using Additional CSS is not better. It blasts everything including posts that should not have full justification. On some themes it can also impact CODE segments.
  2. "Install a plug-in" is never the correct answer. One of the reasons WordPress has become so unstable is with so many marginal plug-ins you can never track down the actual problem.
  3. Switching to HTML and navigating to the blocks that require full justification so one can hack in <p style="text-align: justify;"> is a royal pain.
  4. Professional writers use full justification because that is how we print books too. When you see a ragged edge, that's an amateur.
  5. Professional writers really don't care about idiot phones. We write for people with attention spans longer than a Tweet.
  6. It is unprofessional to provide a feature then take it away. In the IT world this is called regression and it is always undesirable.

#6 follow-up: @sabernhardt
3 months ago

  • Keywords reporter-feedback removed

I thought this was about the Classic Editor. For the block editor, the Gutenberg repo has at least one open discussion about justified text:
https://github.com/WordPress/gutenberg/issues/27300

I still think you would have a better experience putting all the paragraphs you want justified within one block (either Group or Classic), entering a class of "justified" to that block in the settings sidebar, and using something like this in the Additional CSS:

.justified p {text-align:justify;}

#7 in reply to: ↑ 6 @seasoned_geek
3 months ago

Replying to sabernhardt:

I thought this was about the Classic Editor. For the block editor, the Gutenberg repo has at least one open discussion about justified text:
https://github.com/WordPress/gutenberg/issues/27300

When it started 4 years ago, it was about the classic editor.

Full justification was there, then it went away.

Your suggestion about "putting everything into blocks and using custom style tag" is consistent with the lack of reality WordPress/AGILE developers have.

I started writing that blog in 2010. I always flagged paragraphs for full justification. The oldest post on that blog is currently from 2011-05-26. There are currently 763 posts.Every one of which has to be edited to utilize your proposed solution.

A mantra that I beat upon in my award winning technical book series:
https://theminimumyouneedtoknow.com/

is that developers have to consider the installed base.

The installed base was not considered when full justification was removed.

Note: See TracTickets for help on using tickets.