WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#41043 closed defect (bug) (duplicate)

Media > [Insert Into Page] Randomly Removes Content After Place of Insert

Reported by: ilovewpcom Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Editor Keywords: needs-patch
Focuses: Cc:

Description

Hi,

Apparently this is broken since 4.8. Have tested only in "Text" mode, not in Visual.

Clicking the "Insert into Post" or "Insert into Page" button for images will randomly strip a few lines of content that come AFTER the place where you are trying to insert the image.

Notes:

  1. When first loading the Edit Page, the first time I insert the image - it will strip all white space that comes before the cursor in the editor.
  1. When going to insert another (or the same) image again (so basically you open the "Add Media" window twice), the bug occurs.
  1. Have tested this on localhost (2 installations) and on 3 live websites, all with different themes and mostly different plugins. Exactly the same issue.

This is pretty grave, as you can totally miss this bug if you are not attentive.

Change History (4)

This ticket was mentioned in Slack in #themereview by ilovewpcom. View the logs.


2 years ago

#2 @dingo_bastard
2 years ago

  • Component changed from General to Editor
  • Keywords needs-patch added

#3 @dingo_bastard
2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40911.

#4 @netweb
2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.