Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#41193 closed defect (bug) (invalid)

Cannot remove sub-menu item in WP admin which links to admin.php

Reported by: subrataemfluence's profile subrataemfluence Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.5
Component: General Keywords:
Focuses: administration Cc:

Description

I am trying to remove the following sub-menu page
http://vagrant.local/wp/wp-admin/admin.php?page=home_settings_page with the following but it never disappears

remove_submenu_page( 'admin.php', 'home_settings_page' )

But remove_submenu_page( 'options_general.php', 'here_is_the_option' ) works.

Codex page I am referring to is:
https://codex.wordpress.org/Function_Reference/remove_submenu_page

Change History (2)

#1 in reply to: ↑ description @ajayghaghretiya1
7 years ago

Replying to subrataemfluence:

I am trying to remove the following sub-menu page
http://vagrant.local/wp/wp-admin/admin.php?page=home_settings_page with the following but it never disappears

Last edited 7 years ago by ajayghaghretiya1 (previous) (diff)

#2 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

home_settings_page is not a part of WordPress core. This seems like a support issue, so I'd suggest trying the support forums to resolve it: https://wordpress.org/support/.

Feel free to reopen with steps to reproduce on a clean install if it turns out to be an issue in WordPress core.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.