WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 2 months ago

Last modified 4 weeks ago

#41828 closed enhancement (fixed)

Customizer: Rename "Static Front Page" to "Homepage Settings"

Reported by: melchoyce Owned by: melchoyce
Milestone: 4.9 Priority: normal
Severity: normal Version:
Component: Customize Keywords: has-patch commit
Focuses: ui Cc:

Description

From https://make.wordpress.org/design/2017/08/25/page-on-front-lean-ux-canvas/.

I think that we should rename "Static Front Page" to "Homepage Settings."

The idea behind "Static Front Page" (and "Front Page Displays") feels backwards. You always have a homepage, you’re just choosing what content you’d like to display on it. "Homepage," I think, is a pretty well known and understandable concept, vs. "front page," which at this point in the internet is a uniquely WordPress term. It's immediately recognizable.

I know there's some concern from the development side of things, because "homepage" in WordPress is a very specific thing, but I think the general user benefits of renaming this setting to something more familiar trumps minor developer confusion in this particular case.

Note: I am just suggesting changing a label right now. Any more changes will be suggested in new tickets.

Attachments (7)

new-customizer-settings.jpg (19.6 KB) - added by danieltj 3 months ago.
Example of what 41828.diff looks like
41828.diff (1.2 KB) - added by danieltj 3 months ago.
Changed the strings for this section
Screen Shot 2017-09-07 at 8.41.54 PM.png (71.6 KB) - added by melchoyce 3 months ago.
homepage-dictionary.png (44.3 KB) - added by danieltj 3 months ago.
Dictionary definition of 'homepage'
41828.2.diff (4.9 KB) - added by danieltj 3 months ago.
Improved the patch with suggested chages
41828.3.diff (4.9 KB) - added by danieltj 2 months ago.
Variation of the word homepage
41828.4.diff (5.0 KB) - added by westonruter 2 months ago.
Rename Customizer section from “Static Homepage” to just “Homepage”

Download all attachments as: .zip

Change History (30)

This ticket was mentioned in Slack in #design by melchoyce. View the logs.


3 months ago

@danieltj
3 months ago

Example of what 41828.diff looks like

@danieltj
3 months ago

Changed the strings for this section

#2 follow-up: @danieltj
3 months ago

  • Keywords has-patch needs-testing 2nd-opinion added

I've changed the wording within the customizer to make this a bit more understandable and friendly. I think that this is somewhat related to another ticket which focuses of reworking the UI layout and elements for selecting said pages but I can't find it. If someone else can then please do link it here! Anyway, thoughts?

#3 in reply to: ↑ 2 @melchoyce
3 months ago

Thanks for putting this patch together, @danieltj!

What if we changed "Front Page displays" / "Show on homepage" to "Your homepage displays:" instead? I'm attaching a screenshot of what I'm thinking.

Related, I just opened #41829.

I've changed the wording within the customizer to make this a bit more understandable and friendly. I think that this is somewhat related to another ticket which focuses of reworking the UI layout and elements for selecting said pages but I can't find it. If someone else can then please do link it here! Anyway, thoughts?

Sounds like #16379, though more recent updates are being discussed in https://make.wordpress.org/design/2017/07/14/a-better-page-on-front-experience-previous-ideas/ and https://make.wordpress.org/design/2017/08/25/page-on-front-lean-ux-canvas/. :) Once we have a couple ideas in place we can see about making some new follow-up tickets that link back to the old, closed ticket.

#4 @joyously
3 months ago

Can we use real words "home page" instead of "homepage"? How do you translate "homepage"? Why make up a new word?

I think "Front Page" sounds better than a made up word "Homepage".

#5 @melchoyce
3 months ago

Looking up "homepage" vs. "home page" on Google:

Homepage: About 708,000,000 results
Home page: About 339,000,000 results

"Homepage" seems to be the more common usage, though I'd like to hear from some editors.

#6 follow-up: @joyously
3 months ago

Current sites with a made up word doesn't mean much. There are a lot of sites with misspellings and bad grammar and made up words. Why promote it?

Have you considered the confusion of the template hierarchy? home page template
The hierarchy is already confusing about which template file is used: home.php or front-page.php or index.php
The front-page.php is first, and the theme has to make sure the Front Page setting is respected.
The home.php file is always used for the latest posts, whether they are on the front page or a static page.

@danieltj
3 months ago

Dictionary definition of 'homepage'

#7 in reply to: ↑ 6 ; follow-up: @melchoyce
3 months ago

Replying to joyously:

Current sites with a made up word doesn't mean much. There are a lot of sites with misspellings and bad grammar and made up words. Why promote it?

Because people recognize it. Would still like input from a copy editor, though.

Have you considered the confusion of the template hierarchy? home page template
The hierarchy is already confusing about which template file is used: home.php or front-page.php or index.php
The front-page.php is first, and the theme has to make sure the Front Page setting is respected.
The home.php file is always used for the latest posts, whether they are on the front page or a static page.

I'm not super concerned that the folks relying most on this setting being intuitive will also be confused by how it differs from WordPress' template hierarchy. The vast majority of users relying on the Customizer and on settings to create their websites are likely not super familiar with the template hierarchy.

#8 @danieltj
3 months ago

Homepage isn't a made up word, it's in the dictionary. As for translating it, it's up to the translation editors to decide how to translate it. From Dictionary.com it's listed as homepage but in the Oxford Dictionary (UK) it's listed as home page so it's up to the specific locale translators to decide what is best fit.

I'm happy to upload another patch with the changes @melchoyce mentioned in comment 3.

Last edited 3 months ago by danieltj (previous) (diff)

@danieltj
3 months ago

Improved the patch with suggested chages

#9 @danieltj
3 months ago

[41828.2.diff] now also includes the user interface in within the admin area as well. Updated the patch to reflect the suggestions that @melchoyce had suggested earlier.

#10 @michelleweber
3 months ago

FWIW, the WordPress.com standard, per our style guide, is "homepage."

#11 follow-up: @melchoyce
3 months ago

Thanks @danieltj. For some reason I'm seeing your changes to the Customizer, but not to options-reading.php... can someone else test the patch and confirm?

Also — We'll still want to call the Customizer panel "Homepage Settings" (or "home page," though @michelleweber's has me leaning back towards one word.)

#12 @westonruter
3 months ago

  • Keywords 2nd-opinion removed

From an English linguistic perspective, “homepage” is a single compound word now as the stress has moved from the second word to the first. We say “homepage” with stress like we pronounce “blackboard” (surface for writing with chalk, stress on first syllable) not like “black board” (some board that is painted black). In English, a homepage is now a “thing”. Now whether or not the compound noun is spelled with a space in the middle is the only matter for debate, as English is inconsistent (like “White House” vs “a white house”). From search results, clearly it seems “homepage” is winning the spelling war over “home page” by wide margins.

(Another related example: “webmaster” is a thing now, we don't talk about someone being a “web master”, unless we want to describe someone being super good at web stuff or maybe being an overlord of the entire internet.)

Last edited 2 months ago by westonruter (previous) (diff)

#13 follow-up: @netweb
2 months ago

FYI: English (Australia) #en-au uses home page, along with front page, front end, back end

WordPress spelling style guide has the following: https://make.wordpress.org/core/handbook/best-practices/spelling/

  • “back end” (noun) instead of “back-end” or “backend”
  • “back-end” (adjective) instead of “back end” or “backend”
  • “front end” (noun) instead of “front-end” or “frontend”
  • “front-end” (adjective) instead of “front end” or “frontend”

Once a consensus is reached on home page or homepage the WordPress spelling style guide should be updated :)

#14 in reply to: ↑ 11 @danieltj
2 months ago

Replying to melchoyce:

Thanks @danieltj. For some reason I'm seeing your changes to the Customizer, but not to options-reading.php... can someone else test the patch and confirm?

Also — We'll still want to call the Customizer panel "Homepage Settings" (or "home page," though @michelleweber's has me leaning back towards one word.)

I've made a new patch which changes front page to homepage so now we have two options. We can either use homepage or home page. Personally I'd suggest we go for the joint, single word options of homepage as the way forward.

So just to reiterate, 41828.2.diff and 41828.3.diff are the same apart from the variation of the word. So I guess we can just pick which one is best and commit it. I'm not sure why it's not working for you though, I've tested it on my end and seems to do the trick.

@danieltj
2 months ago

Variation of the word homepage

@westonruter
2 months ago

Rename Customizer section from “Static Homepage” to just “Homepage”

#15 @westonruter
2 months ago

  • Keywords commit added; needs-testing removed
  • Owner set to melchoyce
  • Status changed from new to reviewing

#16 @westonruter
2 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 41363:

Customize: Rename "Static front page" to just "Homepage".

Props danieltj, melchoyce.
Fixes #41828.

#17 in reply to: ↑ 13 @netweb
2 months ago

Replying to netweb:

WordPress spelling style guide has the following: https://make.wordpress.org/core/handbook/best-practices/spelling/

I've added "homepage" to this 🔤

#18 in reply to: ↑ 7 ; follow-up: @greenshady
2 months ago

Replying to melchoyce:

Replying to joyously:

Current sites with a made up word doesn't mean much. There are a lot of sites with misspellings and bad grammar and made up words. Why promote it?

Because people recognize it. Would still like input from a copy editor, though.

I can put on my old copy editor hat for a moment. :)

I'd lean toward "home page" simply because it'd be clear to both people new to the Web and those familiar with the lingo. If for no other reason than this clarity, I'd use two words.

While "homepage" has been in use for many years, it'd probably look like a misspelling (thus, unprofessional) to many.

I don't have an updated copy of The AP Stylebook on hand. I'm guessing it'd push for "home page." However, the stylebook tends to change with usage and never sets anything in stone.

If I were editing for a tech magazine, I'd allow for "homepage." For a general newspaper, I'd go with "home page."

---

FWIW, it wouldn't hurt for core WP to adopt a particular stylebook or create its own. It'd help with these types of discussions.

#19 in reply to: ↑ 18 @netweb
2 months ago

Replying to greenshady:

I don't have an updated copy of The AP Stylebook on hand. I'm guessing it'd push for "home page." However, the stylebook tends to change with usage and never sets anything in stone.

Nor do I, AP use home page in two tweets from 2012 & 2015 here (they've never tweeted homepage)

If I were editing for a tech magazine, I'd allow for "homepage." For a general newspaper, I'd go with "home page."

From this year https://english.stackexchange.com/a/112057 cites some references to other style guides usage

tl;dr Tech focused companies prefer homepage over home page

FWIW, it wouldn't hurt for core WP to adopt a particular stylebook or create its own. It'd help with these types of discussions.

This is what https://make.wordpress.org/core/handbook/best-practices/spelling/ is about, not a style guide in its own right, but the best we've got right now ;)

#20 @williampatton
2 months ago

I see at the top any additional changes proposed would be done in additional tickets. Has anyone made any additional proposal tickets yet?

I have no input on the 'homepage' vs 'home page' discussion but I do have some concerns over a fragmentation which could occur with template function name scheme and expected behavior of such functions if the static front page becomes the homepage. If there are any tickets created for those I'd like to share my concerns there as early as possible. Thank you!

Last edited 2 months ago by williampatton (previous) (diff)

This ticket was mentioned in Slack in #core by joyously. View the logs.


2 months ago

#22 @xkon
2 months ago

Homepage as I remember was always a 'thing' for calling the index and I've never personally used a space or dash in there. Way long before 'companies' accepted it so it became more popular than 'home page' or front page etc.

I understand the correct way of spelling things but the Web has it's own ways even if dictionaries aren't updated. So when we're talking about web stuff I'll always use ( let's call it ) web slang, accepted or not I don't care/mind personally.

For example as @netweb mentioned the front end I've never heard a 'simple' fellow saying that at least not in Greece. That's something that only Devs use here. Simple users will instead of front end, back end go for website & admin...

That being said I'd go for Homepage ( but that's a personal preference ).

Also it has nothing to do with the theme building process. I'm making or editing a new theme every week and I'm always getting confused on that part no matter how many times I've done it but that's when I'm looking at the files not when I'm inside the admin panel :D . Most simple users won't even go near the files to get confused by this simple change.

Just my 2c as it was mentioned on the last #core devchat ( see? it's devchat , not dev chat :P ).

This ticket was mentioned in Slack in #polyglots by presskopp. View the logs.


4 weeks ago

Note: See TracTickets for help on using tickets.