Make WordPress Core

Opened 7 years ago

Closed 14 months ago

#42307 closed defect (bug) (duplicate)

Installing WP in Subfolders and https Issue

Reported by: mocha365's profile mocha365 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8.2
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Note sure what component to set this ticket to, but here is the issue.

I have a domain with SSL enabled. I wanted to install WordPress in a subdirectory (folder) while the root of my website is static HTML pages. Installed it, but noticed that the site urls in General settings do not inherit https; they are http only. Change them to https and click save and then I get too_many_redirects error and locked out of admin. Have to go in db to change back to http or do a complete reinstall of WP.

Turns out this is related to "mixed content". I reinstalled WP and before changing http to https, I noticed the source code had shown http (for assets) and https as well mixed in. Reset General settings to https and again, error and locked out.

Finally came across a few plugins for this issue: SSL Insecure Content Fixer and also Really Simple SSL. I tried the first one and it worked, although I still had to manually change the General site url settings to https. Everything worked.

I then disabled the plugin, manually changed the site url to https again, and was locked out again. Reinstalled WP but this time tried the other plugin (which automatically changed the site url setting to https....everything working as well.

So it appears this has been a long-time issue when looking in Google and knowing there are plugins to fix this, means that it's a problem that has been around for a long time with the core and installation of WP in a sub folder on an SSL enabled domain. Technically, people should not require the use of a plugin to solve this.

Change History (3)

#1 @SergeyBiryukov
7 years ago

  • Component changed from General to Upgrade/Install

This ticket was mentioned in Slack in #core-upgrade-install by costdev. View the logs.


14 months ago

#3 @costdev
14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15733.

Hi @mocha365, welcome to Trac and thanks for opening this ticket!

Sorry it's taken so long to respond to your issue!

For those who experience this issue, this comment may help to clarify what might be going on and how it can be solved.

Additional props: @SergeyBiryukov @pbiron @afragen

Per the discussion in the triage, I'll close this ticket.

Note: See TracTickets for help on using tickets.