WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 weeks ago

#42519 closed defect (bug) (worksforme)

Links in AutoUpdate-Mail contain horizontal ellipsis, which causes broken links

Reported by: transl8or Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Upgrade/Install Keywords: close reporter-feedback
Focuses: Cc:

Description

The two textstrings, that appear in an email ...

"Downloading update from %s…"
+
"Downloading translation from %s…"

contain a horizontal ellipsis at the end which is not excluded from the link (href).

This does create broken links in the email that informs users about the update or upgrade of their WordPress and translations.

Links to the strings:
https://core.trac.wordpress.org/browser/trunk/src/wp-admin/includes/class-language-pack-upgrader.php?marks=116#L116

https://core.trac.wordpress.org/browser/trunk/src/wp-admin/includes/class-core-upgrader.php?marks=33#L33
https://core.trac.wordpress.org/browser/trunk/src/wp-admin/includes/class-plugin-upgrader.php?marks=50#L50
https://core.trac.wordpress.org/browser/trunk/src/wp-admin/includes/class-theme-upgrader.php?marks=49#L49

I add a screenshot of a german mail where you can see the broken links.

(I've currently deleted the horizontonal ellipsis in the two strings of the german translations, but thats not a solution for all the other translated languages out there.)

Attachments (1)

AutoUpdate-Mail-Protocoll_with-Broken-Links.png (58.0 KB) - added by transl8or 4 years ago.
AutoUpdate Mail with Broken Links

Download all attachments as: .zip

Change History (7)

@transl8or
4 years ago

AutoUpdate Mail with Broken Links

#1 @ocean90
4 years ago

  • Focuses ui removed
  • Keywords close added
  • Version 4.9 deleted

WordPress sends the emails in plain text so it's up to the email client to correctly parse URLs.

#2 @transl8or
4 years ago

@ocean90 Do you know why there was the <span>-tag removed in the above strings since 4.9

See 4.8:
https://translate.wordpress.org/projects/wp/4.8.x/admin/de/default?filters%5Bterm%5D=Downloading&filters%5Buser_login%5D=&filters%5Bstatus%5D=current&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

versus
4.9
https://translate.wordpress.org/projects/wp/dev/admin/de/default?filters%5Bterm%5D=Downloading+&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filter=Filter&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

I wonder, because I reported the issue (and your answer) to the mailprovider and if they can have a look at it and fix it.

Additional question then was:
"Ist für Sie nachvollziehbar, warum WordPress die gängige Kapselung von
Links innerhalb von spitzen Klammern, also so <posteo.de> nicht nutzt?
Dies schützt in der Regel zuverlässig vor Umbrüchen und
Fehlinterpretationen einer URL."

TBH I just can't answer that.

And it seems its just a problem of the german translations, where we decided to have a &#160; before the &hellip; so that it's consistent and Duden-conform everywhere.

#3 @dd32
4 years ago

  • Severity changed from normal to minor

@transl8or The <span> tags were removed from the translations in https://core.trac.wordpress.org/changeset/41908 but will still appear in emails.

#4 follow-up: @transl8or
4 years ago

Hi @dd32, thanks for pointing that out.
After checking that issue with various other mailclients, it's definitly a parsing problem at Posteo.de, probably because of the "&#160;". I'll leave that to them now.

And have re-approved the translation in german with the "&#160;&hellip; so they have a scenario to reproduce it.

#5 in reply to: ↑ 4 @hellofromTonya
5 months ago

  • Keywords reporter-feedback added

Replying to transl8or:

Hi @dd32, thanks for pointing that out.
After checking that issue with various other mailclients, it's definitly a parsing problem at Posteo.de, probably because of the "&#160;". I'll leave that to them now.

And have re-approved the translation in german with the "&#160;&hellip; so they have a scenario to reproduce it.

Hello @transl8or,

Double checking my interpretation. The issue is not due to core but rather due to a third party, i.e. Posteo.de. Is this correct? If yes, then we can close this ticket.

#6 @hellofromTonya
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket as it seems to be due to a third party conflict rather than core.

However, if it is due to core, @transl8or please reopen with a follow-up.

Note: See TracTickets for help on using tickets.