Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#42627 closed enhancement (duplicate)

Rename the "Text" editor tab to "Code"

Reported by: giuriani Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: accessibility, administration Cc:

Description

This consideration comes from an analysis on a polyglots and accessibility issue during WordCamp Milano contributor day today, and in relation to the possibility that the "Text" tab may confuse the initial WordPress users in addition to the fact that it is not properly correct since it is actually more than a code source editor. It also does not respect the accessibility criteria for voice over to read a misleading and insignificant "Text".

TinyMCE inspired by the current WordPress editor uses the "Source code" label even if it is an actual html.

In addition, the polyglots Spanish community has translated the "HTML" tab, although we all know that "HTML" is incorrect because the text "Text" in the current tab displays a mixture of text and html.

For these reasons I believe that a more appropriate term may be "Code"

Does anyone else think this label should be changed for these reasons? Does the name “Code” make sense?

Previously: #20993

Attachments (1)

TEXT LABEL.png (8.8 KB) - added by giuriani 4 years ago.

Download all attachments as: .zip

Change History (3)

@giuriani
4 years ago

#1 @Presskopp
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38061.

#2 @Clorith
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.