WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#42657 closed defect (bug) (duplicate)

Failure of writing .htaccess from Plugin on WordPress 4.9.0

Reported by: sakurainternet Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9
Component: Plugins Keywords: reporter-feedback
Focuses: Cc:

Description

Hi.
I'm Genki Taniguchi working on SAKURA Internet Inc.

We have a plugin for our hosting service customer.
https://ja.wordpress.org/plugins/sakura-rs-wp-ssl/
AOSSL plugin.

Activate and When the plugin's button clicked, writing some script to htaccess.
And when the plugin deactivated, delete which script.
Problem is this delete function is not work on 4.9.0.
(Writing is working)

On 4.8.3 it worked correctly.My environment is below.
Apache 2.4 PHP 5.6, 7.1 MySQL5.5
Wordpress 4.9.0
htaccess's permission is correct.(664)

Best regard.

Change History (3)

#1 @dd32
2 years ago

  • Keywords reporter-feedback added

Hi @sakurainternet and welcome to Trac.

Thanks for reporting this, although this sounds like it might be caused by #42579 - as it looks like your plugin uses `extract_from_markers()`.

Can you test your plugin by either applying the changes in [42213] or by using the latest 4.9.1-alpha release.

#2 @sakurainternet
2 years ago

Hi @dd32 .

I tryied 4.9.1 alpha and confirmed fixed this problem.
I wait until 4.9.1 will be released.
Thank you so much!

Best regards.

#3 @dd32
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #42579.

Thanks for confirming that!

Note: See TracTickets for help on using tickets.