WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 20 months ago

#42874 reopened defect (bug)

mediaelement-and-player.min.js javascript errors on Add New Post

Reported by: bluesaphyer Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.1
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

I am getting javascript errors on the Add New Post page after upgrading to 4.9.1. I've seen other tickets with similar errors, but the solutions do not seem to help. I have disabled all plugins, set the theme to twenty-twelve, and the language is set to U.S. English. The errors are preventing being able to switch between text and visual editors.

mediaelement-and-player.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:9 JQMIGRATE: Migrate is installed, version 1.4.1
mediaelement-and-player.min.js Failed to load resource: the server responded with a status of 404 (Not Found)
mediaelement-migrate.min.js:1 Uncaught ReferenceError: mejs is not defined
    at mediaelement-migrate.min.js:1
    at mediaelement-migrate.min.js:1
load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load[]=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load[]=,underscore,word-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaeleme&load[]=nt,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check,editor,q&load[]=uicktags,wplink,media-upload,wp-embed&ver=4.9.1:449 Uncaught TypeError: b(...).not(...).filter(...).mediaelementplayer is not a function
    at HTMLDocument.a (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load[]=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load[]=,underscore,word-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaeleme&load[]=nt,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check,editor,q&load[]=uicktags,wplink,media-upload,wp-embed&ver=4.9.1:449)
    at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at Function.ready (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)
    at HTMLDocument.K (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,moxiejs,plupload&ver=4.9.1:2)

Any help you can provide is appreciated.

Change History (9)

#1 @dd32
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @bluesaphyer and welcome to Trac.

This doesn't seem like a bug in WordPress, but quite possibly caused by a failed update - as that file should definitely exist.

I'd recommend reinstalling WordPress's files by going to Dashboard -> Updates and clicking reinstall - you won't loose any data, it's the same as a regular update, it just ensures that all files are present and at the correct version.

If that doesn't resolve the issue, as the file should exist, you may need to seek support from your host or from the WordPress.org support forums.

I'm marking this issue as invalid as it doesn't appear to be a problem with WordPress - please note that you can continue to reply to a closed ticket if needed.

#2 @bluesaphyer
2 years ago

We have 4 separate installs that this is happening on, it doesn't seem like a failed update would happen on all of them.

#3 @bluesaphyer
2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

We reinstalled all of our instances and the same problem is still happening.

#4 @dd32
2 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

@bluesaphyer Assuming you've not already corrected this.

mediaelement-and-player.min.js Failed to load resource: the server responded with a status of 404 (Not Found)

Unfortunately your webserver is responding with a "Sorry, I can't find that file". You'll need to contact your host if reinstalling WordPress didn't help.

I'm reclosing this as invalid as there's no other reports from other users about this. If you have no luck with your hosts support team, the Support Forum Volunteers may be able to help.

#5 follow-up: @bluesaphyer
2 years ago

@dd32 I have not been able to correct this. The file exists on the file system, so it seems wordpress is failing to load it for some reason. I believe the issue is related to https://core.trac.wordpress.org/ticket/42574 and https://core.trac.wordpress.org/ticket/42750 but none of the patches seem to work for me. The only language setting I have available in the admin is English (United States), so I am not able to test selecting a different language.

#6 in reply to: ↑ 5 @dd32
2 years ago

Replying to bluesaphyer:

@dd32 I have not been able to correct this. The file exists on the file system, so it seems wordpress is failing to load it for some reason.

The reason stated in your ticket is mediaelement-and-player.min.js Failed to load resource: the server responded with a status of 404 (Not Found) - specifically meaning that the web server (not WordPress) has rejected the browsers attempt to load the file, by saying the file doesn't exist. That's unfortunately out of the control of WordPress, and means that this isn't a WordPress bug unfortunately.

FYI @bluesaphyer I've contacted you directly on your WordPress.org email with an offer of help.

Last edited 2 years ago by dd32 (previous) (diff)

#7 @alexlii
21 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I have the same issue with the version 4.9.1

If ssl is installed on site, This error Will cause the videos does not play in safari, but iwill play well with chrome and Firefox.

I searched a lot, it seems Jquery related.

Alex

#8 @alexlii
21 months ago

This is definitely a bug.

it only happen with Safari on the site with SSL installed.

here is the error message: Media error: Format(s) not supported or source(s) not foundDownload File:

The author of mediaelement post a notification at https://github.com/mediaelement/mediaelement

  • IMPORTANT NOTE for Safari users (Jun 8, 2017)

Since Sierra version, autoplay policies have changed. You may experience an error if you try to execute play programatically or via autoplay attribute with MediaElement, unless muted attribute is specified.

For more information, read https://webkit.org/blog/7734/auto-play-policy-changes-for-macos/

and here is Apple policy: https://webkit.org/blog/7734/auto-play-policy-changes-for-macos/

Would you please let me know how to resolve?

Alex

#9 @SergeyBiryukov
20 months ago

  • Component changed from General to Media
  • Milestone set to Awaiting Review
Note: See TracTickets for help on using tickets.