WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#42955 closed defect (bug) (duplicate)

Add documentation for js/media/views/attachments.js

Reported by: ireneyoast Owned by: atimmer
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Media Keywords: has-patch
Focuses: javascript, docs Cc:

Description

Add documentation for js/media/views/attachments.js
Please also give props to herregroen, andizer, and jipmoors

Attachments (1)

media-views-attachments-documentation.diff (11.3 KB) - added by ireneyoast 19 months ago.

Download all attachments as: .zip

Change History (9)

#1 @netweb
19 months ago

  • Component changed from General to Media
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 5.0
  • Owner set to atimmer
  • Status changed from new to assigned

#2 @atimmer
19 months ago

  • Keywords close added

I think this is a duplicate of https://core.trac.wordpress.org/ticket/42832.

#3 @netweb
19 months ago

  • Keywords reporter-feedback added; close removed

There are some differences in the media-views-attachments-documentation.diff patch here in this ticket to that of what was committed in [42415]. Probably worth confirming from the original GitHub to see if [42415] had been merged into the GitHub repo or not.

Can anyone confirm any of this please? cc @ireneyoast, @herregroen, @andizer, and @jipmoors

#4 follow-up: @atimmer
19 months ago

I've made some changes to the actual commit that are necessary for the JSDoc parser to be able to parse the documentation correctly. In this specific commit, if there is both documentation on the constructor (initialize with @constructs) and the class (@class) the end result is duplicated documentation.

Like @ireneyoast I have removed all the @summary tags from the previous patch. And fixed the line length. I can ask @ireneyoast to merge master into her branch on GitHub to verify that these differences are all there is. But I am fairly confident that what is on trunk now is correct.

#5 @ireneyoast
19 months ago

@netweb I merged master into our branch, and confirmed that all changes we made are reflected in @atimmer's committed patch.

#6 @ireneyoast
19 months ago

  • Keywords reporter-feedback removed

#7 in reply to: ↑ 4 @netweb
19 months ago

  • Milestone 5.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #42832.

Thanks @ireneyoast & @atimmer +1

This ticket was mentioned in Slack in #core-js by aduth. View the logs.


19 months ago

Note: See TracTickets for help on using tickets.