WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#43928 closed defect (bug) (duplicate)

WordPress treating URL number suffix strangely

Reported by: galapogos01 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.5
Component: Canonical Keywords:
Focuses: Cc:
PR Number:

Description

Hi guys,

Weird one here that has been bought about by Google Search Console showing me Google is indexing hundreds of pages of my site. I raised a support ticket which resulted in the suggestion I raise it here.

WordPress seems to handle any number on the end of a valid URL as if it were a real page, and show it as a separate page, complete with canonical URL tag.

Example:

Real Page: http://www2.cuny.edu/academics/academic-programs/

Fake page - does not actually exist but returns a page: http://www2.cuny.edu/academics/academic-programs/2/

I have used these pages from the wordpress.org sample section as my example to prove its happening not just with my own install (I also tested with default theme & all plugins disabled).

The result of this craziness is that Google will index these many variants of the same page, causing duplicate content issues.

I would have expected WordPress to redirect to the actual page, which would have its own (correct) canonical.

Thoughts? Help!

Change History (3)

#1 @subrataemfluence
20 months ago

Welcome to Trac and thanks for the ticket!

I confirm that the issue is happening for me as well in several of my sites and even for a fresh install with bundled theme and no third party plugin installed.

Weird!

#2 @SergeyBiryukov
20 months ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @galapogos01, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #28081.

#3 @galapogos01
20 months ago

Thanks @SergeyBiryukov and thanks to @subrataemfluence for confirming I am not going mad.

@SergeyBiryukov, the linked ticket is 4 years old! What can we do to get some priority on this?

The indexing of the dummy pages causes real issues for SEO.

I have written a quick hack for the get_canonical_url filter to trim off the number but this is a hack only.

Thanks,
Jason

Last edited 20 months ago by galapogos01 (previous) (diff)
Note: See TracTickets for help on using tickets.