Make WordPress Core

Opened 5 years ago

Closed 6 months ago

Last modified 3 months ago

#44515 closed defect (bug) (duplicate)

Multisite: "Deactivate" And "Delete" Labels Are Confusing

Reported by: conner_bw's profile conner_bw Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.6
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

Problem: Some of our admins accidentally "Deleted" their sites when all they really wanted to do was "Delete" their site. (?!)

wp-admin/network/sites.php

  • "Deactivate" sets delete column to 1 in wp_blogs, recoverable action.
  • "Delete" runs wpmu_delete_blog() with $drop = true, unrecoverable action.

wp-admin/network/site-info.php?id=2

  • "Deleted" sets delete column to 1 in wp_blogs, recoverable action.

Suggestion: Change "Deleted" to "Deactivated"

$attribute_fields['deleted'] = __( 'Deactivated' );

https://github.com/WordPress/wordpress-develop/blob/97cacadc50716695d8c8d3afe129d901f4230266/src/wp-admin/network/site-info.php#L186

'deleted' => array( 'site-deleted', __( 'Deactivated' ) ),

https://github.com/WordPress/wordpress-develop/blob/97cacadc50716695d8c8d3afe129d901f4230266/src/wp-admin/includes/class-wp-ms-sites-list-table.php#L41

Attachments (1)

multisite-deactivate-vs-delete.png (59.4 KB) - added by conner_bw 5 years ago.

Download all attachments as: .zip

Change History (7)

#1 follow-up: @conner_bw
5 years ago

  • Type changed from defect (bug) to enhancement

#2 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Networks and Sites

#3 in reply to: ↑ 1 @afoc
4 years ago

I agree that some more clarity on this would be nice.

#4 @afoc
4 years ago

  • Type changed from enhancement to defect (bug)

Additionally, when a site is deactivated and it shows up in the site list highlighted in red, it should say "deactivated" and not "deleted".

I disagree that this is an enhancement rather than a defect, because it is a conflation of two very distinct, widely understood English words. The implications of an admin making this mistake, which specifically would only happen because WP core confusingly misuses "delete" to mean "deactivate" in a few different areas, are both startling and destructive.

#5 @ideag
6 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #15801

#6 @desrosj
3 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.