WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#45270 closed task (blessed) (duplicate)

5.0 Upgrade – add an information message for Assistive Technologies users

Reported by: audrasjb Owned by: lonelyvegan
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: accessibility Cc:

Description

See also this slack discussion in Make/Accessibility: https://wordpress.slack.com/archives/C02RP4X03/p1541173818360700

The main goal of the ticket is to validate the wording and the modus operandi to display it to website admins.

Ideally, the message should be displayed in WordPress update page and on the welcome page.

Wording proposal:

"Do you use screen readers, screen zoom utilities, or other accessibility tools to use WordPress? You may have noticed that the new WordPress editor experience (Gutenberg) may still have issues with your tools. We’re still working on it. If you don’t mind testing and providing feedback, that would be super helpful! But we totally understand if that’s not possible. You can install the classic editor plugin while we keep working on making the new editor experience better and more accessible. Thank you for your patience and support as we make the WordPress editor experience better for everyone!"

Change History (20)

#1 @audrasjb
11 months ago

  • Owner set to lonelyvegan
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


11 months ago

#4 @lonelyvegan
10 months ago

I'm no copy editor, so feel free to ping those people if you like too. But I don't think leading with a question is good and I think the copy, while upbeat, is a bit too verbose 😅

I also think it should support/contextualise its position, so I propose something shorter and with references:

"If you use screen readers, screen zoom utilities, or other assistive technology: the new WordPress editor experience (Gutenberg) may still have issues with your tools (https://make.wordpress.org/accessibility/2018/10/29/report-on-the-accessibility-status-of-gutenberg/). If you are experiencing issues using Gutenberg with your assistive technology, you can install the Classic Editor plugin while work on making the new editor more accessible. Thank you for your patience and support as we make the WordPress editor experience better for everyone!"

(I can't make WikiFormatting links work because the Trac help doc isn't great and I never use WikiFormatting. 😅)

#5 @lonelyvegan
10 months ago

  • Keywords reporter-feedback added

Having presented this issue to the other WordPress 5.0 Release Leads: there isn't a plan for any kind of in-dashboard messaging for this notice. @matt suggested that the Classic Editor Plugin description would be a useful place to include info about its use for users of assistive technology.

I understand that adding info to the Classic Editor doesn't satisfy the point raised in Slack: some users won't know if they [i]needi the Classic Editor plugin.

While I appreciate the point of this ticket, there won't be an in-dashboard place for this messaging so I'm not sure where it should go.

Aside from the Classic Editor description (which users won't see if they don't know they need it): where should this live?

(Though keep in mind the Classic Editor will be a featured plugin, so it will have more visibility than the average plugin.)

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


10 months ago

#7 @afercia
10 months ago

For reference, the Trac ticket for the Welcome page (also known as "About" page) with mockups etc. is https://core.trac.wordpress.org/ticket/45178

#8 @lonelyvegan
10 months ago

The bottom of that mockup includes a reference to the Classic Editor. It's possible a brief note regarding Accessibility could go there, but I would want to make clear who we recommend the Classic Editor to there. For instance: do you recommend it for high contrast or zoom text users? Or just screenreader users? A specific call-out could work. 🤔

#9 @joedolson
10 months ago

Can this be part of the Welcome screen for 5.0?

#10 @lonelyvegan
10 months ago

I would be happy to propose that if the text were cut down. When I presented the text, as-is, to the other release leads for 5.0 I was told there weren't plans to include this text at all, but especially nothing that verbose.

I think there's limited space and the messaging should be concise. Ultimately I think an addendum to the section on the Classic Editor like:

"Users of assistive technology who experience usability issues with Gutenberg should use the Classic Editor."

#11 @afercia
10 months ago

Also related:

Upgrading to 5.0 and handling the Gutenberg plugin #45073

#12 @afercia
10 months ago

  • Keywords reporter-feedback removed

For instance: do you recommend it for high contrast or zoom text users? Or just screenreader users?

As pointed out in the accessibility team report, the recommendation to keep using the Classic Editor relates to (quoting): "anybody who has a need for assistive technology".

#13 @afercia
10 months ago

I'd like to add a short consideration: we're all here to serve the WordPress users to the best of our ability. In any open source project, I'd expect the highest openness and transparency towards users. I don't see the notice proposed here as something that can diminish the work made on Gutenberg and its goals. Instead, I see it as a great example of responsibility and transparency.

We're working on it to make it better for everyone. Right now, we're not fully there, yet. The community who has closely followed the project is already informed, and the leads and contributors of the project have already acknowledged (to different degrees) accessibility in Gutenberg is not ideal yet. I don't see a good reason to not inform the wider audience of users in a proper way.

On https://make.wordpress.org/core/2018/11/07/classic-editor-plugin-support-window/ I also read that:

Since the Classic Editor plugin is central in this transition, we are considering including it with upgrades to WordPress 5.0. New WordPress installs would still add it manually, and we’ve included it in the Featured Plugins list to increase visibility. If you have thoughts on this idea, please leave a comment.

If that happens, it could definitely help. At that point, maybe it would be enough to have a notice pointing users to the plugins screen. Thank you.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


10 months ago

#15 @wingo5315
10 months ago

Put it in the release notes somewhere. Preferably at the top.

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


10 months ago

#17 @sami.keijonen
10 months ago

Any progress on this?

#18 @pento
10 months ago

  • Milestone 5.0 deleted
  • Resolution set to duplicate
  • Status changed from reviewing to closed

This message was added to the About page as part of [43913], so I'm going to close this as a duplicate of #45178.

#19 @afercia
10 months ago

So for history and reference, and for users who can't install 5.0 beta or see an image, as of today the message in the about page is made of two parts:

At the top of the page, there's a link pointing to in-page content:

Welcome to WordPress 5.0

Thank you for updating to the latest version! WordPress 5.0 introduces a robust new content creation experience.
Learn how to keep using the old editor.

The targeted section of the page contains some more detailed information:

Keep it Classic

Prefer to stick with the familiar Classic Editor? No problem! Support for the Classic Editor plugin will remain in WordPress until 2021.

The Classic Editor plugin restores the previous WordPress editor and the Edit Post screen. It lets you keep using plugins that extend it, add old-style meta boxes, or otherwise depend on the previous editor. To install, visit your plugins page and click the “Install Now” button next to “Classic Editor.” After the plugin finishes installing, click “Activate.” That’s it!

Note to users of assistive technology: if you experience usability issues with Gutenberg, we recommend you continue to use the Classic Editor.

Install the Classic Editor

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


10 months ago

Note: See TracTickets for help on using tickets.