WordPress.org

Make WordPress Core

Opened 13 months ago

Last modified 6 weeks ago

#45764 reopened defect (bug)

blog page and homepage the same list pages and not posts

Reported by: BackuPs Owned by:
Milestone: Awaiting Review Priority: normal
Severity: minor Version: 5.0.2
Component: Posts, Post Types Keywords: 2nd-opinion
Focuses: ui, administration Cc:
PR Number:

Description

Hi

I don't know when this was changed but if you set the same page as blog page aswell as your homepage the website starts listing pages on that blog and home page and not posts.

Why was this changed and when?

Thanks for any advice.

Change History (10)

#1 @fahimmurshed
13 months ago

I think your theme has a problem!

Can you please attach the problem screenshot?

Explain more.

#2 @BackuPs
13 months ago

Really? You are kidding right? LOL

Just so you know: I tried the default wordpress theme 20-17 and it has the issue. This is what i tested before reporting the problem.

Just create a page called xxxxx with no content at all and set it as your default blog page and also as the default homepage in the wp reading settings and you will see a page list in the homepage and not a post list.

https://cl.ly/d0e8a94b90ec

Moreover

if i only set the page as the blog page it is also not listing any posts anymore.

If i only set it as the home page it is also not listing any posts any more.

I think there is something seriously wrong with wp. It is only listing posts when you dont set any default home page and default blog page.

Last edited 13 months ago by BackuPs (previous) (diff)

#3 @fahimmurshed
13 months ago

Hi,
I am not kidding with you :)

You can't set the same page at the time on homepage and blogpage

Watch this video: https://streamable.com/t8ut0

https://i.imgur.com/LwieLee.png

#4 @BackuPs
13 months ago

Hi

I am sorry but i have the feeling that you are not reading what my issue is or trying to understand the problem if i read your answers.

Because wp gives you a WARNING message that the pages set in the reading settings should not be the same does not mean that it does not work and that you can't do so. You could and can do so. And if you did you got a list of posts when you opened that page.

If you can't then build in a check and if somebody does this then just don't save one of them and revert one of the two back to -- select -- instead of displaying a warning message.

There are two issues in my report here about WP 5.0.2 !

1) Before in earlier versions 4.9.x when you did set both to the same page, the homepage just listed the posts when you did so. Now it is listing the pages. Why? Apparently you can set them the same as you get some result but different then before. I dont want to see the pages. I want to see the posts like it used to be before in wp 4.9x.

My question is why am i getting the pages listed in my homepage and not the posts when i set the Home Page and Blog Page the same?

Why did WP change this behaviour? What reason can WP have to do this? I am not saying this is a bug as WP changed this behaviour.

But if you can't set them the same why is it showing me a page list and not a post list like before? Apparently something changed for a reason ! Which one?

2) (Read carefully as this is a bug in my opinion and a different problem) Before if you only set any page to the Post Page and left the Home page to -- Select --, the Blog Page, when viewed in the front of your website, showed you a list of posts...... What do you get now in WP 5.0.2? Nothing ! No posts at all. This is incorrect. This used to work also correctly in wp 4.9.x !

It is not about what you can't, It's about what you could and can and what is shown. I want to see the posts in both cases ( 1) and 2) ) like it worked before in previous wp versions.

WP users sometimes set these settings and when they do, the info should be consistent and show the same like it did since day one of WP: It showed the posts !

I came across this issue because people where complaining about getting the wrong results. So i tested it with the theme they where using and saw the problem. Then of course i started testing with the default themes to rule out any issues with the theme they where using and i got the same results. Even the default WP themes have the issue now.

So i believe it is not a theme issue (the easy, without testing, answer i guess), but a wp issue. Try to understand the problem here and try not to focus about what you can't and should not do because of a warning message in the admin area.

Before it always worked correctly and now it does not anymore. Something has changed and I wonder what and want to know why? If you can't set the same then why suddenly change the behaviour of the results? That does not make any sense. If it's not allowed to make them the same then why even bother changing the code?

I would like to know if there is a fix to have the correct results like it used to work in previous wp versions and a fix for issue 2) as that i believe is a BUG !

It is as really simple as that.

Last edited 13 months ago by BackuPs (previous) (diff)

#5 @fahimmurshed
6 weeks ago

Hi,

Are you face the problem on the WordPress 5.3?

#6 @BackuPs
6 weeks ago

Hi

After 12 months you get back to me and ask me to check this? This is really a joke.

You could have answered that question simply by testing it !

I must say I am really dissatisfied the way wordpress handles reported bugs.

Anyway, to answer your question : I reported 2 issues. One is resolved the other one is not.

1) My question is why am i getting the pages listed in my homepage and not the posts when i set the Home Page and Blog Page the same?

I just installed a clean install and created a page. Set that page as the blog page and the homepage.

Now the home page still lists pages instead of posts! So reported issue 1) is not fixed.

2)Before if you only set any page to the Post Page and left the Home page to -- Select --, the Blog Page, when viewed in the front of your website, showed you a list of posts...... What do you get now in WP 5.0.2? Nothing ! No posts at all. This is incorrect. This used to work also correctly in wp 4.9.x !

In 5.3 the second issue is fixed.

#7 @knutsp
6 weeks ago

I can confirm that if both is set to the same page, pages are shown on this (home) page as if they were posts - using Twenty Twenty.

I believe these are not intended to be the same, since if posts are to be listed on the home page, the first option "Your latest posts" should be selected.

Should it really be possible to set those to the same? I think that if both are set to the same page, revert to the first option, so that this is impossible to save using UI.

What strange mechanism makes pages listed in his case? Could it be an "Easter egg"?

Last edited 6 weeks ago by knutsp (previous) (diff)

#8 @BackuPs
6 weeks ago

@knutsp Thank you for your reply.

Of course they should not be set the same. But if set the same they should both list the posts and not the pages. Making it impossible to set the same might cause issues when both are set to -select- in which case the homepage lists the posts and not the pages... LOL ... which is the correct thing todo !

So in short when both set to -select- the homepage lists the post.

when only set the blog page, the home page also lists the blog posts.

The only strange thing is when both set to any page then the homepage lists the pages.

Weird behaviour. And this use to work just fine in 4.9.x

Something along the way to V 5 got changed.

#9 @fahimmurshed
6 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

@BackuPs,

I just checked open ticket and I am not part of core team. I just like you :)

Yes, I checked then I ask that I can't get the issue on the latest version.

Anyway, thanks for your reply.

#10 @knutsp
6 weeks ago

  • Component changed from General to Posts, Post Types
  • Focuses ui administration added
  • Keywords 2nd-opinion added
  • Resolution worksforme deleted
  • Severity changed from normal to minor
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.