WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

#46011 closed defect (bug) (duplicate)

Argument types mismatch

Reported by: subrataemfluence Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-patch
Focuses: docs, coding-standards Cc:

Description

A lot of areas of wp-inclues/comment-template.php arguments types described in function Doc-blocks are reported mismatched with that of actual arguments in function declaration.

I searched Trac repo and unable to find a ticket specific to this.

Attachments (2)

46011.diff (5.6 KB) - added by subrataemfluence 3 years ago.
46011.2.diff (4.2 KB) - added by mukesh27 3 years ago.
Updated Patch. Change some docs and change false placement as per other docs.

Download all attachments as: .zip

Change History (6)

@mukesh27
3 years ago

Updated Patch. Change some docs and change false placement as per other docs.

#1 follow-ups: @earnjam
2 years ago

  • Version 5.0.3 deleted

Clearing the version since this isn't specific to 5.0.3 and these docblocks apply to functions added at different times.

Also just a suggestion to each of you @mukesh27 and @subrataemfluence. When you make your patches, you should generate them from the root, so it would include src/ in the path of the file(s) being edited.

#2 in reply to: ↑ 1 @subrataemfluence
2 years ago

Thank you @earnjam . I will follow this in my future patches.

Replying to earnjam:

Clearing the version since this isn't specific to 5.0.3 and these docblocks apply to functions added at different times.

Also just a suggestion to each of you @mukesh27 and @subrataemfluence. When you make your patches, you should generate them from the root, so it would include src/ in the path of the file(s) being edited.

#3 in reply to: ↑ 1 @mukesh27
2 years ago

@earnjam Thanks for your guidance. Will follow it in future patches.

Replying to earnjam:

Clearing the version since this isn't specific to 5.0.3 and these docblocks apply to functions added at different times.

Also just a suggestion to each of you @mukesh27 and @subrataemfluence. When you make your patches, you should generate them from the root, so it would include src/ in the path of the file(s) being edited.

#4 @davidbaumwald
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like this is a duplicate of #46931. Closing this one in favor of that, as the work there has a bit more coverage.

Note: See TracTickets for help on using tickets.