Make WordPress Core

Opened 5 years ago

Closed 2 months ago

#46221 closed defect (bug) (worksforme)

Twenty Nineteen: Horizontal scrollbar Issue in verse block

Reported by: utsav72640's profile utsav72640 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots has-patch
Focuses: Cc:

Description

When i add verse block in editor and assign Alignment Right from
the editor it's Horizontal scrollbar Issue.

Attachments (4)

verse.gif (284.2 KB) - added by utsav72640 5 years ago.
See tha Error
46221.patch (619 bytes) - added by poena 5 years ago.
Reverted padding to the default 1em on the right side to prevent scroll
verse.png (13.2 KB) - added by poena 5 years ago.
Screenshot of the editor with patch applied
46221-iframed-editor.png (125.7 KB) - added by poena 2 months ago.
Right aligned verse block on WordPress 6.5 RC

Download all attachments as: .zip

Change History (10)

@utsav72640
5 years ago

See tha Error

#1 @utsav72640
5 years ago

Above issue will fixed if we add overflow hidden from below css code.

.wp-block-verse pre, pre.wp-block-verse {
color: #191e23;
white-space: nowrap;
font-family: inherit;
font-size: inherit;
padding: 1em;
overflow: hidden;
}

#2 @laurelfulford
5 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from Awaiting Review to Future Release

Thanks for the report, @utsav72640!

I can confirm I can see this issue using Twenty Nineteen in Chrome (though in Firefox it doesn't happen). It's not happening with the other default themes, so it appears to be theme-specific.

Unfortunately adding overflow: hidden will cause too-long text strings to become difficult to edit -- it is good if it still scrolls as long as there's something to scroll to. But there must be something in the themes styles causing the scroll to happen even when it's not needed.

#3 @utsav72640
5 years ago

Thanks @laurelfulford ,

So,I think users is very confused so you will able to solve this??

@poena
5 years ago

Reverted padding to the default 1em on the right side to prevent scroll

@poena
5 years ago

Screenshot of the editor with patch applied

#4 @poena
5 years ago

  • Keywords has-patch added; needs-patch removed

#5 @poena
2 months ago

  • Keywords close added

I have re-tested the issue, without the patch, on WordPress 6.5 RC2 with theme version 2.7.
On macOS, with Chrome, Safari and Firefox.
I can not reproduce the issue.

I tested both with and without the iframed editor (I had the custom fields UI enabled with classic meta boxes)

I suggest closing this issue as fixed.

@poena
2 months ago

Right aligned verse block on WordPress 6.5 RC

#6 @sabernhardt
2 months ago

  • Keywords close removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I'll close this because I also was unable to reproduce the horizontal scroll in WordPress 6.5 RC2 and Twenty Nineteen 2.7, using Windows 10 and both Chrome and Firefox. However, I did not experience the horizontal scroll with WordPress 5.0 either, so I could not compare it to the original issue.

If you still experience the problem, please reopen this ticket and share your browser and operating system details.

Note: See TracTickets for help on using tickets.