WordPress.org

Make WordPress Core

Opened 10 months ago

Last modified 9 months ago

#46250 reopened defect (bug)

smaller fonts for page navigation in admin in 5.1

Reported by: joneiseman Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:
PR Number:

Description

In WordPress 5.1 I noticed the font used for going to the next page and previous page on admin pages got smaller (and thus harder to use).
Here's what it looks like
https://drive.google.com/open?id=1itgRoXGUB8tIW8iJtog2tHe_5uPJ6s4d
The "Posts" page is okay since it uses the "Tablenav-pages" class. But for other plugins that don't use that class, it doesn't look very good. I found two with this problem: GigPress and AIOWPS.
I see it's related to this change: https://make.wordpress.org/core/2019/01/14/new-styling-for-admin-table-pagination-links-in-wordpress-5-1/

Change History (3)

#1 @swissspidy
10 months ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41858.

There were some changes to WordPress 5.1 in this area, see https://make.wordpress.org/core/2019/01/14/new-styling-for-admin-table-pagination-links-in-wordpress-5-1/

All plugin and theme developers should verify that this change does not affect them.

#2 @joneiseman
10 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This really isn't a plugin problem. The plugins use the function paginate_links and paginate_links doesn't display these arrows correctly. It needs to add the "button" class to the arrows to get it to work properly in WordPress 5.1.

Here's the change that fixes the problem:

adapti24@usm90 # diff general-template.php*
3934c3934
<               $page_links[] = '<a class="prev page-numbers button" href="' . esc_url( apply_filters( 'paginate_links', $link ) ) . '">' . $args['prev_text'] . '</a>';
---
>               $page_links[] = '<a class="prev page-numbers" href="' . esc_url( apply_filters( 'paginate_links', $link ) ) . '">' . $args['prev_text'] . '</a>';
3967c3967
<               $page_links[] = '<a class="next page-numbers button" href="' . esc_url( apply_filters( 'paginate_links', $link ) ) . '">' . $args['next_text'] . '</a>';
---
>               $page_links[] = '<a class="next page-numbers" href="' . esc_url( apply_filters( 'paginate_links', $link ) ) . '">' . $args['next_text'] . '</a>';

The left side file is the new one.

Last edited 10 months ago by joneiseman (previous) (diff)

#3 @SergeyBiryukov
9 months ago

  • Milestone set to Awaiting Review
Note: See TracTickets for help on using tickets.