WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 7 weeks ago

#46328 closed defect (bug) (fixed)

Long spam link mobile view

Reported by: Marius84 Owned by: davidbaumwald
Milestone: 5.6 Priority: normal
Severity: minor Version: 3.9
Component: Comments Keywords:
Focuses: ui, css Cc:

Description

I got some spam comments with long link. When I access admin dashboard trough mobile phone and go to the spam comment section the text "Item" cover "Empty Trash" text.

Screenshot: https://prnt.sc/mp1m7i

Attachments (6)

IMG_5298.PNG (295.4 KB) - added by Marius84 2 years ago.
common.css.patch (338 bytes) - added by sharaz 2 years ago.
46328.diff (364 bytes) - added by donmhico 2 years ago.
Update the common.css.patch.
46328.1.diff (639 bytes) - added by donmhico 2 years ago.
Fix overflowing long link and overlapping comment count in Empty Trash button issue.
46328.2.diff (638 bytes) - added by audrasjb 6 months ago.
patch refreshed against trunk
spam-comments-screen-5-7.png (69.8 KB) - added by sabernhardt 7 weeks ago.
Spam comments screen (Firefox responsive mode, extended view, WordPress 5.7)

Download all attachments as: .zip

Change History (35)

@Marius84
2 years ago

#1 @earnjam
2 years ago

  • Focuses ui added
  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to Future Release
  • Version changed from 5.1 to 3.9

Thanks @Marius84! I am able to replicate this.

It looks like it's due to this rule on line 1900 in /wp-admin/css/list-tables.css

.widefat * {
        word-wrap: normal;
}

It overrides the default break-word value for .widefat * in the common css file, but I'm not sure why specifically. I'd be a bit weary of changing that for how many things it would affect. Might be better to target the comments list table directly, or even the specific paragraph tag where these things are overrunning the container.

@sharaz
2 years ago

#2 @sharaz
2 years ago

  • Keywords has-patch added; needs-patch removed
  • Resolution set to invalid
  • Status changed from new to closed

#3 @sharaz
2 years ago

  • Keywords has-unit-tests dev-feedback added
  • Resolution invalid deleted
  • Status changed from closed to reopened

#4 @earnjam
2 years ago

  • Keywords needs-testing added; has-unit-tests removed

This ticket was mentioned in Slack in #core by sharaz. View the logs.


2 years ago

#6 @SergeyBiryukov
2 years ago

  • Milestone changed from Future Release to 5.3
  • Owner set to SergeyBiryukov
  • Status changed from reopened to reviewing

#7 @SergeyBiryukov
2 years ago

  • Keywords needs-patch added; has-patch dev-feedback needs-testing removed

In my testing, the overlapping of "Empty Trash" and "1 item" happens regardless of the long URL. Looks like absolute positioning is not ideal for smaller screens like this.

common.css.patch fixes the URL wrapping, but not the overlapping.

#8 @donmhico
2 years ago

common.css.patch doesn't work for me. See my screenshot - https://prnt.sc/opdcvf

@donmhico
2 years ago

Update the common.css.patch.

@donmhico
2 years ago

Fix overflowing long link and overlapping comment count in Empty Trash button issue.

#9 @donmhico
2 years ago

  • Keywords has-patch added; needs-patch removed

#10 @davidbaumwald
22 months ago

@SergeyBiryukov Are you still up for including this one in 5.3?

This ticket was mentioned in Slack in #core by marybaum. View the logs.


22 months ago

#12 @davidbaumwald
22 months ago

  • Keywords commit added

This one was brought up in today's scrub. This looks like a good candidate for 5.3, so marking for commit.

#13 @marybaum
22 months ago

  • Keywords needs-testing added

#14 @davidbaumwald
22 months ago

  • Keywords commit removed
  • Milestone changed from 5.3 to Future Release

With 5.3 RC1 releasing today, this ticket is being moved to Future Release. If any committer feels this can be worked in to 5.3 before the deadline or can assume ownership in the 5.4 cycle, feel free to move it back up.

#15 @audrasjb
6 months ago

  • Keywords needs-refresh added; needs-testing removed
  • Milestone changed from Future Release to 5.7

Hi, the patch needs to be refreshed against trunk but it looks like it solves the issue (I reproduced the issue recently). Adding this on the 5.7 list.

@audrasjb
6 months ago

patch refreshed against trunk

#16 @audrasjb
6 months ago

  • Keywords needs-refresh removed

This ticket was mentioned in Slack in #core by sergey. View the logs.


6 months ago

#18 @hellofromTonya
6 months ago

  • Keywords commit added

From Sergey:

There's a refreshed patch, seems like a good commit candidate

Marking as a commit candidate.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

#21 @hellofromTonya
5 months ago

  • Milestone changed from 5.7 to 5.8

With 5.7 RC1 minutes away, moving this to 5.8 which will allow the fix to go through a full beta cycle.

#22 @davidbaumwald
4 months ago

  • Owner changed from SergeyBiryukov to davidbaumwald

#23 @davidbaumwald
4 months ago

  • Keywords needs-testing-info added

@audrasjb Looking to move this one forward. Can you provide some information on how to reproduce the original issue and how to test the latest patch resolves the issue?

#24 @audrasjb
4 months ago

  • Keywords needs-testing-info removed

@davidbaumwald to reproduce the original issue, put long links into the content of some comments marked as spam and try to visit the page using a small screen browser. See the first screenshot provided by the reporter.

#25 @audrasjb
4 months ago

  • Keywords commit removed

Hmmm… looks like the issue was already solved by another patch.
Now we have this in common.css:

.widefat * {
	word-wrap: break-word;
}

#26 @davidbaumwald
4 months ago

  • Keywords reporter-feedback added

@audrasjb Thanks for the information! I am unable to reproduce the original issue locally in Chrome and Firefox at any break point.

@Marius84 Can you confirm this is still an issue in WordPress 5.7?

This ticket was mentioned in Slack in #core by chaion07. View the logs.


7 weeks ago

#28 @chaion07
7 weeks ago

  • Milestone changed from 5.8 to Future Release

Thanks to @Marius84 for reporting this. We recently reviewed this during a recent [bug-scrub session]https://wordpress.slack.com/archives/C02RQBWTW/p1623098868382200. With Beta 1 coming up in a day and still waiting on Reporter Feedback we feel that this could be a good candidate for future Releases. Milestone updated. Thanks

@sabernhardt
7 weeks ago

Spam comments screen (Firefox responsive mode, extended view, WordPress 5.7)

#29 @sabernhardt
7 weeks ago

  • Focuses css added
  • Keywords good-first-bug has-patch reporter-feedback removed
  • Milestone changed from Future Release to 5.6
  • Resolution set to fixed
  • Status changed from reviewing to closed

Long links wrap to the next line, apparently since WordPress 5.4 with [46790]/#48805, and the positioning overlap was fixed for 5.6 in [49178]/#49246.

(The screenshot shows 414x896 dimensions)

Note: See TracTickets for help on using tickets.