WordPress.org

Make WordPress Core

Opened 17 months ago

Last modified 10 months ago

#46537 reopened defect (bug)

Can't use Emoji in the Custom HTML widget

Reported by: hirofumi2012 Owned by: SergeyBiryukov
Milestone: Future Release Priority: normal
Severity: normal Version: 4.8.1
Component: Emoji Keywords: has-screenshots needs-patch
Focuses: Cc:

Description

Type emoji. Then the cursor does not move.

Attachments (2)

emoji.png (43.2 KB) - added by hirofumi2012 17 months ago.
46537.diff (1.1 KB) - added by pento 14 months ago.

Download all attachments as: .zip

Change History (13)

@hirofumi2012
17 months ago

#1 @hirofumi2012
17 months ago

  • Keywords has-screenshots added

#2 @SergeyBiryukov
16 months ago

  • Version changed from trunk to 4.8.1

Introduced in #40907.

@pento
14 months ago

#3 @pento
14 months ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to 5.3

This is a problem with all CodeMirror instances (eg, the plugin editor).

46537.diff stops emoji replacement from happening inside CodeMirror instances, it also cleans up some of the logic in the MutationObserver.

Note that polyfills are broken when SCRIPT_DEBUG is enabled (#46110), so this patch can only be tested on IE11 with SCRIPT_DEBUG set to false.

#4 @pento
14 months ago

#44301 was marked as a duplicate.

#5 @davidbaumwald
11 months ago

  • Keywords commit added; needs-testing removed

Confirmed the bug in IE11, and tested the patch which resolved the issue. Marking this for commit.

#6 @SergeyBiryukov
10 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 46393:

Emoji: Stop emoji replacement from happening inside CodeMirror instances, and clean up some logic in the MutationObserver.

Props pento, hirofumi2012, davidbaumwald.
Fixes #46537.

#7 @peterwilsoncc
10 months ago

  • Keywords needs-patch added; has-patch commit removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening as this is throwing errors in the e2e tests:

@davidbaumwald mentioned on Slack it may be due to IE11 not supporting `Element.closest()`.

I am also wondering if it's related to MutationObserver.observe() containing both Nodes and Elements, only the later includes closest(), but haven't done anything so silly as to test the theory ;)

#8 @SergeyBiryukov
10 months ago

In 46397:

Emoji: Revert [46393] pending test failure investigation.

See #46537.

This ticket was mentioned in Slack in #core by marybaum. View the logs.


10 months ago

#10 @marybaum
10 months ago

  • Milestone 5.3 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

#11 @garrett-eclipse
10 months ago

  • Milestone set to Future Release
  • Resolution invalid deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.