Make WordPress Core

Opened 17 years ago

Closed 16 years ago

#4663 closed defect (bug) (fixed)

cannot load plugin

Reported by: mrwizard's profile mrwizard Owned by:
Milestone: 2.3 Priority: high
Severity: major Version: 2.2.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

---> Using WP v2.2.1 the newest build as of 7/20/2007

Some plugins use wp-admin/options.php to update their parameter settings.

Paths to the plugin folder get changed via a urlencode function in this file. So a plugin options file located at...

wp-content/pluginName/plugin-options.php

gets changed to...

wp-content/pluginName2Fplugin-options.php

and the admin.php file errors this out with a message...

CANNOT LOAD pluginName2Fplugin-options.php

The problem is in the wp-admin/options.php file around about line 112.

$goback = preg_replace('|[a-z0-9-~+_.?#=&;,/:]|i', , $goback);

needs to be changed to...

$goback = preg_replace('|[a-z0-9-~+_.?#=&;,/:%]|i', , $goback);

(note the addition of the % symbol)

This change keeps the %2F in the path instead of just 2F.

Perhaps there's another way.... but this worked for me. If you guys know a better way, please let me know.

Tim

Attachments (1)

4663.diff (503 bytes) - added by Nazgul 17 years ago.

Download all attachments as: .zip

Change History (5)

#1 @foolswisdom
17 years ago

  • Milestone set to 2.3 (trunk)
  • Version set to 2.2.1

@Nazgul
17 years ago

#2 @Nazgul
17 years ago

  • Keywords has-patch added

Patch based on given code snippet attached.

#3 @ryan
16 years ago

wp_redirect already does the sanitiation. I think that goback sanitization line can be removed.

#4 @ryan
16 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6042]) Remove redundant url filter. fixes #4663

Note: See TracTickets for help on using tickets.