WordPress.org

Make WordPress Core

#46936 closed feature request (duplicate)

Obfuscate E-mail Address Feature

Reported by: warengonzaga Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback close
Focuses: Cc:

Description

I know this is a clever idea but this would help to stop spamming and also prevent auto bots to scrap your site for emails. Just a suggestion. I hope the next build will be implementing this. I want to contribute... this is my first report.

Change History (6)

#1 @SergeyBiryukov
17 months ago

  • Component changed from General to Customize

#2 follow-up: @desrosj
17 months ago

  • Keywords reporter-feedback added

@warengonzaga Can you provide more details? I am not sure which feature you are referring to. Bots are not able to access the Customizer, and there are no email fields there by default. Are you using a default theme?

#3 in reply to: ↑ 2 @warengonzaga
17 months ago

Replying to desrosj:

@warengonzaga Can you provide more details? I am not sure which feature you are referring to. Bots are not able to access the Customizer, and there are no email fields there by default. Are you using a default theme?

I am using different themes but I know there is a way to make this feature default to all theme makers. So every time we add an email address or phone number details or sensitive information it should obfuscate automatically. The best idea to make this information converted to HTML entities and will render normally in the front end.

#4 @desrosj
17 months ago

@warengonzaga, sorry if I am missing something obvious, but I still do not know what feature you are actually referring to. Can you maybe provide some screenshots? Or some steps to take to see the feature you are talking about?

#5 @dlh
10 months ago

  • Keywords close added
  • Version 5.1.1 deleted

A Customizer control could be set to a type of email, but, as far as I can figure, the Customizer has no knowledge of how the underlying setting is being used, including whether the value can be safely rendered with a function like antispambot(). Unless I'm misunderstanding, I'm thinking this request is better-suited for theme developers than the Customizer.

#6 @dd32
10 months ago

  • Component changed from Customize to General
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Obfuscate E-mail Address Feature in Theme Customizer to Obfuscate E-mail Address Feature

antispambot() is an old function in WordPress to do exactly what's being requested here, obfuscate emails in content to prevent spambots picking them up.

Unfortunately, all obfuscation attempts are ultimately invalidated by WordPress including support for it - the moment WordPress implements something to obfuscate, yet still be human readable, is the time where spambots iterate to pick up on the new obfuscation method, creating a cat-and-mouse type race.
Smart spambots can even pick up emails contained within images through advanced OCR.

The best alternative to obfuscating emails, is to prevent the need for them to be inserted into content in the first place, through using a Contact Form plugin.

Previously: #30214 and #19993 - I'm going to close this as a duplicate of the latter.

Note: See TracTickets for help on using tickets.