WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4746 closed defect (bug) (duplicate)

Bug involving "application/xhtml+xml"

Reported by: Stevie212 Owned by:
Milestone: Priority: low
Severity: normal Version: 2.2.2
Component: Administration Keywords: mime, type, dashboard, bug
Focuses: Cc:

Description

The mime type "application/xhtml+xml" causes a weird bug with the WP dashboard, if used instead of "text/html" it will cause the the Planet Wordpress feeds not to show at the bottom of the dashboard, the development blog feed does, but not the WP planet feeds, and it all happens because of this mime type. While many users won't be affected, I believe that this is some sort of a minor defect that should be looked into. No need for a screenshot as it happens with any WP, in this case 2.2.2. Try it and you'll see what I mean.

Close this if it is already been discovered.

Change History (5)

#1 @DD32
14 years ago

Error only happens because the HTML which index-extra.php returns is invalid for XML parsing.

Firefox chokes on it by look of it, Opera handles it fine when its being dynamically loaded, yet throws an erorr when viewed directly.

see for yourself:
http://SiteURL/wordpress/wp-admin/index-extra.php?jax=planetnews

I believe this is likely a dupe too.

Just remember that IE6(at least) cant handle anything thats serviced with application/xhtml+xml as well.

#2 @Stevie212
14 years ago

I'm well aware of that, however it seems almighty weird that only one feed loads and the other doesn't. Apparently this issue has already been brought up damn! my first bug report and it was already reported. It is however a defect.

#3 @DD32
14 years ago

I thought it was a dupe, But i couldnt find it :)
Move discussion over there and close this ticket i guess.

#4 @JeremyVisser
14 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3914.

#5 @Nazgul
14 years ago

  • Milestone 2.2.3 deleted
Note: See TracTickets for help on using tickets.