WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#47729 closed defect (bug) (duplicate)

Hierarchical terms ordered strangely when selected in admin interface

Reported by: danieltj Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: ui Cc:
PR Number:

Description

The way hierarchical taxonomy terms are displayed within the classic editor is confusing and I believe needs updating to properly reflect the order/structure of said terms when they're selected.

I've checked the interface of Gutenberg as part of WordPress 5.2.2 and this seems to be addressed so it's just classic editor meta box thing strangely enough.

When you select a term, and it's parent term, any siblings that are not selected are left orphaned at the bottom of the category meta box list which means in some instances they're out of context and can be hard to identify which parent category they below to.

I'll attach some screenshots to illustrate my point further.

I think this is a bug but it breaks the hierarchical structure and will lead to confusion for the user.

Attachments (3)

47729-categories-selected.png (43.1 KB) - added by danieltj 7 months ago.
Categories are in order but post has not been saved yet.
47729-post-saved.png (43.2 KB) - added by danieltj 7 months ago.
Categories selected but in incorrect order after post saved.
47729-gutenberg-ui.png (33.1 KB) - added by danieltj 7 months ago.
The Gutenberg interface exhibiting the correct behaviour.

Download all attachments as: .zip

Change History (4)

@danieltj
7 months ago

Categories are in order but post has not been saved yet.

@danieltj
7 months ago

Categories selected but in incorrect order after post saved.

@danieltj
7 months ago

The Gutenberg interface exhibiting the correct behaviour.

#1 @ocean90
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10982. See also #20054 for changing the default behaviour with a filter.

Note: See TracTickets for help on using tickets.