WordPress.org

Make WordPress Core

Opened 4 weeks ago

Closed 4 weeks ago

#48389 closed defect (bug) (invalid)

Upload image not working

Reported by: dkarfa Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

Updating failed. Error message: step is not a function

Attachments (2)

Screenshot 2019-10-21 21.32.46.png (142.7 KB) - added by dkarfa 4 weeks ago.
Screenshot 2019-10-22 08.17.58.png (71.6 KB) - added by dkarfa 4 weeks ago.

Download all attachments as: .zip

Change History (8)

This ticket was mentioned in Slack in #core-media by mike. View the logs.


4 weeks ago

#2 @SergeyBiryukov
4 weeks ago

  • Keywords reporter-feedback added

Hi there, thanks for the report!

Which WordPress version are you using? Does the issue still happen with all plugins disabled and a default theme activated?

#3 @dkarfa
4 weeks ago

I am using a development version (5.3-RC1-20191021.213028) and not a single plugin is activated.

#4 @azaozz
4 weeks ago

@dkarfa what is your testing env. like? Are you running Apache? I get similar 404 API errors when .htaccess is out of date/incorrect. For example running WP from /src vs. running it from /build.

Loading the Settings=>Permalinks screen should refresh .htaccess, could you try it and see if it makes a difference.

Last edited 4 weeks ago by azaozz (previous) (diff)

#5 @dkarfa
4 weeks ago

I am using VVV for my localhost.

#6 @azaozz
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Was able to reproduce this in a checkout of trunk that was a bit older. Caused by outdated dependencies. Running npm install before building should fix it, thanks to @youknowriad for figuring it out :)

Closing as invalid for now. Please feel free to reopen if the above fix doesn't work.

Note: See TracTickets for help on using tickets.