WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 3 months ago

Last modified 2 weeks ago

#48494 closed enhancement (duplicate)

Option to expand admin menu with click instead of hover

Reported by: sjnbham Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Toolbar Keywords:
Focuses: ui, administration Cc:

Description

Change the behavior of admin menu top-level links. Have them expand on click instead of on hover events. This will improve accessibility:

https://www.liquidlight.co.uk/blog/navigation-drop-downs-should-they-be-hover-or-click/

It would also address another issue:

https://core.trac.wordpress.org/ticket/48471#comment:6

If there are concerns about preference, this could be an option instead of removing the ability to hover entirely, but onclick could be the default.

Change History (3)

#1 @sabernhardt
3 months ago

  • Keywords close added

The current plan on #48894 is to make all of the toolbar's dropdowns expand on click (when JavaScript is enabled).

@sjnbham If you want to add to the discussion on #48894, please comment there.

This ticket probably could be closed as a duplicate of the other, if the direction on that ticket stays the same.

#2 @sjnbham
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed
Last edited 3 months ago by sjnbham (previous) (diff)

#3 @desrosj
2 weeks ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Type changed from defect (bug) to enhancement
  • Version 5.2.4 deleted
Note: See TracTickets for help on using tickets.