WordPress.org

Make WordPress Core

Opened 17 months ago

Last modified 4 months ago

#48888 new defect (bug)

HTML being stripped from shortcode blocks in blog posts

Reported by: kmwade Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

Hi team

I have a MailChimp newsletter signup form in the sidebar of my blog. Occasionally I add the same signup form to the body of my blog posts. Previously when I have done this, the one from the sidebar has been removed and just the one in the blog post is displayed.

I tried to do this yesterday and discovered that wherever I have done this, now neither signup form shows. I asked my tech guy to take a look and he found that whenever the shortcode for the newsletter signup form is included in a blog post, the HTML is being stripped from the code meaning it’s not displayed. He suggested I try adding the form to a blank page and embedding it in my blog post to fix the issue. I did this using Elementor and it didn’t work.

My tech guy is fairly sure this is a bug as he doesn’t think any of the HTML should be being messed with. And he said he’s fairly sure it’s a WordPress bug not a plugin or theme bug.

I am unsure how long this issue has being going on for. Has anyone else reported a similar bug?

I’m using the latest stable version of WP.

Change History (3)

#1 @kmwade
17 months ago

Here is an example of where the issue is occurring https://kmwade.com/writing-for-business/promote-blog-social-media/

#2 @SergeyBiryukov
17 months ago

  • Component changed from General to Editor

#3 @noisysocks
4 months ago

  • Keywords reporter-feedback added

Hi @kmwade. Are you still running into this issue? Does it happen if you disable all plugins except Mailchimp and activate a default theme e.g. Twenty Twenty? Could you please share the shortcode that are you trying to insert?

Note: See TracTickets for help on using tickets.