WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 10 months ago

#49675 closed defect (bug) (fixed)

correct documentation for WP_User_Request class

Reported by: pbiron Owned by: SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: normal Version: 4.9.6
Component: Privacy Keywords: has-patch commit
Focuses: docs Cc:

Description

In the DocBlocks for the properties of the class, the @since tags are missing and the @type tags for $email, $confirmed_timestamp and $completed_timestamp props are wrong:

  • $email should be type string
  • the other 2 should be type int|null

Attachments (1)

49675.diff (2.3 KB) - added by pbiron 17 months ago.

Download all attachments as: .zip

Change History (7)

@pbiron
17 months ago

#1 @pbiron
17 months ago

  • Keywords has-patch added

#2 @SergeyBiryukov
17 months ago

  • Milestone changed from Awaiting Review to 5.5
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#3 @garrett-eclipse
17 months ago

  • Keywords commit added
  • Milestone changed from 5.5 to Awaiting Review

Thanks @pbiron this looks good. @SergeyBiryukov beat me to milestoning and owning so I'll let him finish reviewing, but this looks good to commit in my view.

#4 @garrett-eclipse
17 months ago

  • Milestone changed from Awaiting Review to 5.5

Oops didn't mean to unmilestone it, should have refreshed before submitting.

#5 @SergeyBiryukov
17 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 47494:

Docs: Add missing @since tags for WP_User_Request properties.

Correct type for $email, $confirmed_timestamp, and $completed_timestamp properties.

Props pbiron, garrett-eclipse.
Fixes #49675.

#6 @garrett-eclipse
10 months ago

  • Focuses privacy removed

Dropping privacy focus as it's already in the Privacy component.

Note: See TracTickets for help on using tickets.