WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#49727 closed defect (bug) (fixed)

Dashboard widgets toggle arrow is not vertically middle in small screens.

Reported by: chetan200891 Owned by: SergeyBiryukov
Milestone: 5.5 Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-screenshots has-patch
Focuses: ui Cc:

Description

In Dashboard widget, in mobile view toggle arrow for widgets is not in vertically centered. It is due to margin-top. Added by post/page meta boxes. Another option is we can make title h2 with same padding as in page/post meta boxes.

Attachments (3)

Dashboard-Widgets-Before.png (69.0 KB) - added by chetan200891 8 months ago.
Before.
49727.diff (440 bytes) - added by chetan200891 8 months ago.
Initial patch.
Dashboard-Widgets-After.png (68.2 KB) - added by chetan200891 8 months ago.
After applying patch.

Download all attachments as: .zip

Change History (7)

@chetan200891
8 months ago

Initial patch.

@chetan200891
8 months ago

After applying patch.

#1 @SergeyBiryukov
8 months ago

  • Milestone changed from Awaiting Review to 5.5
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#2 @chetan200891
8 months ago

  • Keywords has-patch added

#3 in reply to: ↑ description @SergeyBiryukov
8 months ago

Thanks for the ticket!

In Dashboard widget, in mobile view toggle arrow for widgets is not in vertically centered. It is due to margin-top. Added by post/page meta boxes.

This appears to be a regression in WordPress 4.8 introduced in [40059], which removed the .button-link class from these arrows. Previously, .wp-core-ui .button-link { margin: 0; } used to override these extra 3 pixels.

Another option is we can make title h2 with same padding as in page/post meta boxes.

I think this would be the preferred option here. It would make the size of the heading in post meta boxes and dashboard widgets consistent.

#4 @SergeyBiryukov
8 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 47535:

Administration: Make the height of dashboard widget headings consistent with that of post meta boxes on smaller screens.

This also ensures that the toggle arrow for dashboard widgets is properly aligned.

Props chetan200891.
Fixes #49727.

Note: See TracTickets for help on using tickets.