WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 9 months ago

#49890 closed defect (bug) (reported-upstream)

Media/Text Block: Cropped Linked Image Background Display Issue

Reported by: JarretC Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-screenshots
Focuses: Cc:

Description

Came across the issue on this thread here:

https://wordpress.org/support/topic/media-text-block/

While posted in the TwentyFourteen support forum, this is happening on TwentyTwenty as well. The issue happens when you create a Media/Text block, define an image, link it to a URL and then set it to "Crop image to fill entire column" when the width of the media "column" in the block is wider than the image being used.

To replicate...

  1. Create Media/Text block
  2. Upload/insert a narrow image, around 400px wide is appropriate
  3. Add default text to the right of the image
  4. Link the image to the media/attachment page or any URL
  5. Set "Crop image to fill entire column" in the Media & Text settings
  6. Ensure that the width (blue circle icon slider) of the media in the block is set wider than the width of the image

https://i.snipboard.io/1KJvcf.jpg

You can see in the screenshot, the original 150x150 pixel image at the top left and then the "cropped" image displaying across the entire width that was set in the Media/Text block.

Change History (3)

#1 @SergeyBiryukov
17 months ago

  • Component changed from General to Editor

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


9 months ago

#3 @talldanwp
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

@JarretC Thanks for reporting this. Just so you know for next time, block editor issues are reported in the Gutenberg github repository:
https://github.com/WordPress/gutenberg/issues

This was also reported there by another user (https://github.com/WordPress/gutenberg/issues/21399), and it looks like this has been fixed by this change:
https://github.com/WordPress/gutenberg/pull/27211

The fix was released in version 9.6 of the plugin. I tried to reproduce the issue, and it does indeed look fixed for Gutenberg plugin users. Unfortunately the fix was too late for WordPress 5.6, but it will be in a future version.

Note: See TracTickets for help on using tickets.