Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 2 years ago

#50542 closed enhancement (fixed)

Twenty Twenty: Add Support for wa.me (WhatsApp's preferred link)

Reported by: macmanx's profile macmanx Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch has-dev-note
Focuses: Cc:

Description

#49098 added support for WhatsApp to the Social Menu, which is awesome, but it expects the URL to contain "whatsapp.com" whereas per https://faq.whatsapp.com/general/chats/how-to-use-click-to-chat/ these links are now under "wa.me"

I recommend keeping "whatsapp" (the links used to be api.whatsapp.com long ago) but also adding a mapping for "wa.me" to /classes/class-twentytwenty-svg-icons.php

Reported via https://wordpress.org/support/topic/how-to-add-a-custom-social-icon/

Attachments (2)

50542-twentytwenty.diff (557 bytes) - added by sabernhardt 3 years ago.
50542-twentyseventeen.diff (564 bytes) - added by sabernhardt 3 years ago.

Download all attachments as: .zip

Change History (7)

#1 @sabernhardt
3 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 5.9

We should update Twenty Seventeen as well.

#2 @sabernhardt
3 years ago

The Twenty Seventeen issue was already reported on #51946, so that patch is uploaded there now.

#3 @SergeyBiryukov
3 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 51618:

Twenty Twenty: Add support for wa.me links in Social menu.

This ensures that wa.me links, currently preferred by WhatsApp, have the same icon as whatsapp.com links.

Follow-up to [47243], [51617].

Props sabernhardt, macmanx.
Fixes #50542.

#4 @desrosj
3 years ago

In 51693:

Coding Standards: Apply some minor alignment fixes.

These are updates caused by running composer format.

Follow up to [51501], [51599], [51618], [51653].
See #53359, #50542, #53238, #53668, #53690.

#5 @sabernhardt
2 years ago

  • Keywords has-dev-note added

The Bundled themes update note has a section about this.

Note: See TracTickets for help on using tickets.