WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#50872 closed feature request (duplicate)

Default link to media file when inserting images or gallery

Reported by: vigilant_spb Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.4.2
Component: Media Keywords:
Focuses: ui, administration Cc:

Description

There are many complaints about no default option for inserted images to link to a media file (set none by default). Any working solution?

  • If I have to add 50 photos I should click link-media file 50 times, instead of setting up default value.. Old version (classic editor) had ways to set this default link, but old method doesn't work with Gutenberg 🙁

I saw

https://github.com/WordPress/gutenberg/issues/10173
https://wordpress.org/support/topic/how-to-link-to-media-file-by-default/
https://wordpress.org/support/topic/can-the-pics-link-be-set-to-media-file-by-default/
https://wordpress.org/support/topic/adding-links-to-images-in-wordpress-5/

and others, all closed/left, no working solution for 2 years
any ideas?

Change History (3)

#1 @SergeyBiryukov
4 months ago

  • Component changed from General to Media

#2 follow-up: @SergeyBiryukov
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #46390.

#3 in reply to: ↑ 2 @vigilant_spb
4 months ago

Replying to SergeyBiryukov:

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #46390.

thanks, tried to find it but didn't succeed

Note: See TracTickets for help on using tickets.