WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 6 months ago

Last modified 6 months ago

#51103 closed enhancement (fixed)

Twenty Fourteen: Add Block Patterns

Reported by: melchoyce Owned by: ryelle
Milestone: 5.8 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch needs-copy-review needs-codex needs-dev-note
Focuses: Cc:

Description

With block patterns introduced in WordPress 5.5, we now have the opportunity to add some patterns to our older default themes.

Let's consider adding some patterns to Twenty Fourteen.

@iamtakashi, since you were the designer for the theme, would love to get your input here.

Change History (25)

This ticket was mentioned in Slack in #design by melchoyce. View the logs.


15 months ago

#2 @hellofromTonya
14 months ago

  • Milestone changed from 5.6 to Future Release

With Beta 1 for 5.6 landing in less than 2 weeks, punting this ticket to Future Release. If any maintainer or committer feels this can be resolved in time, or wishes to assume ownership during a specific cycle, feel free to update the milestone accordingly.

#3 @beafialho
14 months ago

Here are some block pattern design proposals:
https://cloudup.com/ciWstplePgD

#4 follow-up: @kjellr
14 months ago

Thanks @beafialho! I like these ones the best:

https://cldup.com/jIGKu9CULd-3000x3000.png

https://cldup.com/IITolcUdtx-3000x3000.png

https://cldup.com/jNn2al3mgz-3000x3000.png

I like this last one too, but I wonder if it could be a little shorter?

https://cldup.com/PU2wcYrtat-3000x3000.png

#5 @melchoyce
14 months ago

Agreed, I think those patterns show off blocks the best.

#6 in reply to: ↑ 4 @beafialho
14 months ago

@kjellr yes, I made it shorter: https://cloudup.com/cpqATvr9ih4

#7 @kjellr
14 months ago

Awesome, that looks great. Thank you!

This ticket was mentioned in PR #1006 on WordPress/wordpress-develop by kjellr.


10 months ago

  • Keywords has-patch added

Trac ticket: https://core.trac.wordpress.org/ticket/51103

---

This PR adds block patterns to Twenty Fourteen, along with the associated images.

Screenshots:

https://i0.wp.com/user-images.githubusercontent.com/1202812/107991390-87499c00-6fa4-11eb-8973-6d66b6e0f223.png
https://i0.wp.com/user-images.githubusercontent.com/1202812/107991393-87e23280-6fa4-11eb-95f8-9ce846cc1d24.png

#9 follow-up: @kjellr
10 months ago

@beafialho + @melchoyce I pushed a patch that includes these patterns. I edited the copy a bit to eliminate the Lorem Ipsum, and I also curated the images a bit so that they had a little more of a dreamy/nostalgia feel to them. Let me know if those work from your perspective!

#10 @kjellr
10 months ago

  • Keywords needs-copy-review added; needs-design removed

I'm also going to add "Needs Copy Review" here to get some additional eyes on the text!

#11 in reply to: ↑ 9 @beafialho
10 months ago

@kjellr thank you, they all look great!

#12 @desrosj
9 months ago

  • Milestone changed from Future Release to 5.8

I'm going to move this to 5.8. But, if they are ready sooner we can move this to 5.7.1 (or if that's not realistic, move to Future Release).

We can also release an update detached from a specific WordPress release as we did in December.

#13 @poena
7 months ago

When I test the PR with Gutenberg version 10.7 RC1 only two patterns show up, the contact and summary.
I will follow this up with an issue on the Gutenberg GitHub repo https://github.com/WordPress/gutenberg/issues/32139

Last edited 7 months ago by poena (previous) (diff)

#14 @onemaggie
7 months ago

Updated the alt texts with esc_attr on this one too. Looks good to go.

#15 @kjellr
7 months ago

Thanks @onemaggie. Assuming that issue @poena found is a Gutenberg one, I agree this should be ready to go too.

#16 @poena
7 months ago

It just looks like the format of the
content inside register_block_pattern is handled stricter.
Without response from the editor team, this might well be intentional.

There is additional spacing between the blocks in the block markup in the patterns that are not showing. That can be fixed in the themes.

And themes that uses array() to separate the pattern content into individual lines does not have this problem.

This ticket was mentioned in Slack in #core-themes by kjell. View the logs.


7 months ago

#18 @jffng
7 months ago

I can confirm what @poena said re: TwentyFourteen patterns — removing the line breaks fixes the issue, and all four patterns appear.

I have a commit that does this @kjellr if you want to give me permission to your wordpress-develop fork to update the PR + diff.

#19 @kjellr
7 months ago

Go for it, thanks @jffng!

#20 @lukecarbis
7 months ago

The decision was made on Slack to keep this (and other theme pattern tickets) open after the feature freeze date.

https://wordpress.slack.com/archives/C01VACX5E2W/p1621972702066300

This ticket was mentioned in Slack in #core-themes by kjell. View the logs.


6 months ago

#22 @jffng
6 months ago

We made a small change to ensure the text color was visible in one of the patterns. I gave them all another test, and they appear ready to land.

#23 @ryelle
6 months ago

  • Owner set to ryelle
  • Resolution set to fixed
  • Status changed from new to closed

In 51045:

Bundled Themes: Introduce block patterns for Twenty Fourteen.

Props beafialho, kjellr, melchoyce, onemaggie, poena, jffng, jeffikus.
Fixes #51103.

#24 @prbot
6 months ago

ryelle commented on PR #1006:

This was committed in r51045.

#25 @milana_cap
6 months ago

  • Keywords needs-codex needs-dev-note added
Note: See TracTickets for help on using tickets.