WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#51833 closed defect (bug) (duplicate)

Jquery UI issue with Google Lighthouse

Reported by: a223123131 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: External Libraries Keywords:
Focuses: Cc:

Description

Googles Web Vitals will become rancing factor in Google starting May. Web Vitals are based on Lighthouse and Lighthouse is based on 4 elements, one is called "Pest Practices". Under this section it reports the following:

*

Includes front-end JavaScript libraries with known security vulnerabilities 1 vulnerability detected

Library Version: jQuery UI@1.11.4
Vulnerability Count: 1
Highest Severity: High

*

There are no plugins which updates this. Looks like you need to de-register the default WP version and register an own. Think this is to much for most users and should pe fixed within WP 5.7.

I place this ticket as "bug" because there is no typ "security" available and it is not an enhancement or feature request.

Attachments (1)

lighthouse-bp.jpg (62.1 KB) - added by a223123131 6 months ago.
Lighthouse Screenshot

Download all attachments as: .zip

Change History (3)

@a223123131
6 months ago

Lighthouse Screenshot

#1 @Soean
6 months ago

WordPress 5.6 updates jQuery UI to v1.12.1, see #50564

Last edited 6 months ago by SergeyBiryukov (previous) (diff)

#2 @SergeyBiryukov
6 months ago

  • Component changed from General to External Libraries
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome back to WordPress Trac! Thanks for the ticket.

As noted above, this is addressed in #50564.

Note: See TracTickets for help on using tickets.