WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 6 weeks ago

Last modified 4 weeks ago

#52374 closed defect (bug) (fixed)

Twenty Twenty-One: Menu button has the wrong colors

Reported by: poena Owned by: SergeyBiryukov
Milestone: 5.7 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch
Focuses: css Cc:

Description (last modified by SergeyBiryukov)

An unintended side effect of the updated button styles in #51927 was that the menu button changed color.

In trunk, the current menu button has a dark grey background color
var(--global--color-primary); and a transparent text.

As per design, the background should be transparent and the text should be dark grey.

Attachments (3)

menu-button-trunk.png (6.1 KB) - added by poena 6 weeks ago.
Menu button with incorrect colors
52374.patch (8.4 KB) - added by poena 6 weeks ago.
Override specificity from default button styles by using the button ID.
with-patch.png (30.6 KB) - added by jeroenrotty 4 weeks ago.
Mobile menu button with correct styling

Download all attachments as: .zip

Change History (9)

@poena
6 weeks ago

Menu button with incorrect colors

@poena
6 weeks ago

Override specificity from default button styles by using the button ID.

#1 @poena
6 weeks ago

  • Keywords needs-testing added

#2 @SergeyBiryukov
6 weeks ago

  • Description modified (diff)

#3 @SergeyBiryukov
6 weeks ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 50026:

Twenty Twenty-One: Correct colors for the Menu button.

As per design, the background should be transparent and the text should be dark grey, not vice versa.

Follow-up to [49987].

Props poena.
Fixes #52374. See #51927.

@jeroenrotty
4 weeks ago

Mobile menu button with correct styling

#4 @jeroenrotty
4 weeks ago

Tested the patch with @rolfsiebers and the patch worked as intended, see screenshot.

This ticket was mentioned in Slack in #core by francina. View the logs.


4 weeks ago

#6 @hellofromTonya
4 weeks ago

  • Keywords has-patch added; needs-testing removed
Note: See TracTickets for help on using tickets.