WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 13 days ago

#5294 closed defect (bug) (duplicate)

$phpmailer->Sender line prevents comment notifications from being received

Reported by: stitzelj Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords:
Focuses: Cc:

Description (last modified by foolswisdom)

$phpmailer->Sender line prevents comment notifications from being received on hosts that do "callout verification" unless wordpress@[domain] is a valid email address.

WORKAROUNDS

Ensure, that the email address wordpress@[domain] is a valid email address.

OR

Remove the following line in wp-includes/pluggable.php which was added in WP 2.3.1:

228  $phpmailer->Sender = apply_filters( 'wp_mail_from', $from_email ); 

Attachments (1)

no-sender.php (379 bytes) - added by westi 7 years ago.
WordPress plugin to reverse the change

Download all attachments as: .zip

Change History (25)

comment:1 @Viper007Bond7 years ago

  • Milestone changed from 2.5 to 2.3.2
  • Version set to 2.3.1

Works just fine for me, so it must be a server configuration thing.

comment:2 @stitzelj7 years ago

Hm, that figures. And I have no control over server settings, so I guess I'll just have to tag that line out everytime I upgrade from now on.

comment:3 @foolswisdom7 years ago

stitzelj, hopefully not, the trick is figuring out why it doesn't work for you, and how general the problem is.

comment:4 @stitzelj7 years ago

Any suggestions on what I can check on my end are welcome.

comment:5 @foolswisdom7 years ago

My guess is this relates to #5273, and "callout verification". If you create an email address of wordpress@[blogdomain] do you receive the comments? (Or update $from_email in pluggable.php to be equal to an existing email address)

comment:6 @stitzelj7 years ago

Neither of those corrected the problem.

comment:7 @stitzelj7 years ago

As it turns out, ticket #5273 that you pointed out is a problem for me, as well. I have a multi-author blog I'm also running that takes new contributors as they come, and neither of the last two that have signed up (both since I upgraded to 2.3.1) have received their verification emails and get email server connection errors when they try to request a new email with a password.

comment:8 @westi7 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

comment:9 follow-up: @danahuff7 years ago

I am having the same problem, and it appears that the e-mails being sent out to people who subscribe to my blog might not be receiving them. I had quite a few bounced e-mails in my main box.

comment:10 @stitzelj7 years ago

Problem solved once I set up the wordpress@[domain] email address. I messed up the initial setup of the account earlier, which is why it didn't seem to fix the problem. I've re-uploaded the original 2.3.1 version of the pluggable.php file, and it works fine. Apparently, the original root email address that was set up when bought my account was no longer adequate when I upgraded to 2.3.1.

comment:11 in reply to: ↑ 9 @foolswisdom7 years ago

Followed up with danahuff by email, and her issue doesn't seem to relate. It seems to be a hosting issue.

comment:12 @foolswisdom7 years ago

  • Description modified (diff)
  • Summary changed from $phpmailer->Sender line prevents comment notifications from being sent to $phpmailer->Sender line prevents comment notifications from being received

comment:13 @foolswisdom7 years ago

  • Description modified (diff)

comment:14 @Sportech7 years ago

Removing the line in pluggable.php solved my problem. I would hate to have to make this fix everytime I upgrade wordpress

@westi7 years ago

WordPress plugin to reverse the change

comment:15 follow-up: @westi7 years ago

Could you try the attached plugin to see if this also fixes the issue for you.

This should ensure you don't have to change core files

comment:16 in reply to: ↑ 15 @Sportech7 years ago

Replying to westi:

Could you try the attached plugin to see if this also fixes the issue for you.

This should ensure you don't have to change core files

This plugin worked.

comment:17 @haniobaid7 years ago

I've been running without issues for several months. Stopped getting comment notification emails as soon as I upgraded from 2.3 to 2.3.1

Added wordpress@… email to my bluehost cpanel. it didn't help.

Tried the plugin above, also didn't help

comment:18 @haniobaid7 years ago

I removed the line mentioned above from pluggable and now I get the emails

comment:19 @silkenhut7 years ago

I followed the instructions here like

creating the wordpress@…
deleting line 228 from pluggable.php
and even installing/activating the plug-in

but I still can't receive any emails.

comment:20 @lloydbudd7 years ago

silkenhut, the 1st step may be to work with your host to confirm that the emails are being sent, and what happens to them.

comment:21 @geoffarnold7 years ago

Just one more data point: I installed 2.3.1, and had no problem with email notifications; then I upgraded to PHP5 (yeah, I know), and started losing most (but not all) notifications. I deleted the infamous line 228, but it didn't help.

comment:22 @santosj7 years ago

Upgrading to PHP5 shouldn't have caused this issue. Is it possible to downgrade to PHP4 and see that it works? Also, if you still have the old PHP4 installation on another site, see what the phpinfo() says. Specifically, about send_mail (or sendmail), compare the two, if you can and report back.

comment:23 @lloydbudd7 years ago

  • Milestone 2.3.2 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #5273 .

comment:24 @paulistabmw13 days ago

I would like to thank the giant stitzelj and westi the great tip! I could solve my problem just by changing the word "From" with "Sender" on line 382 of file pluggable.php! now receive e-mail notifications of wordpress version 4.1 without problems! I leave the code here for anyone wanting to $phpmailer->From = apply_filters( 'wp_mail_from', $from_email ); see one print: http://i.imgur.com/TM1Hq5m.png?1 excuse my terrible English, I'm Brazilian! big hug

Note: See TracTickets for help on using tickets.