Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#53730 closed defect (bug) (wontfix)

too many tables after plugin unstallation

Reported by: cadentic2018's profile cadentic2018 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords: reporter-feedback
Focuses: Cc:

Description

hi

there are tons of plugins and preset widgets are flowing in. but the problem is when we install a plugin it is not cleaning up all the tables that it had created. which creates excessive problems for en users. all of these plugin authors should maintain an uninstallation guideline for the cleanup procedure.

even the most famous jetpack CRM is having the same problem including any other plugins.
deactivations and deletions of plugins are not enough, we must have the complete cleanup procedure.
thx
sayantan

Change History (2)

#1 @hellofromTonya
3 years ago

  • Component changed from General to Plugins
  • Keywords reporter-feedback added
  • Version 5.8 deleted

Hello @cadentic2018,

Welcome to WordPress Core Trac!

I can appreciate the impact of artifacts left behind by a plugin that customized the site but did not clean up during its uninstall process. But I'm confused about what you're asking to be fixed in WordPress. Could you please provide more details?

all of these plugin authors should maintain an uninstallation guideline for the cleanup procedure.

Yes, I agree. The responsibility is within the plugin that added artifacts (such as a new database table) to determine what and if these need to be cleaned during its uninstall process. In some cases, another plugin may be also be using the new table or a decision was made to retain the data instead of deleting it. But the knowledge of what and when lies within the plugin.

deactivations and deletions of plugins are not enough, we must have the complete cleanup procedure.

Are you asking for the cleanup process to be moved into WordPress Core instead of each plugin doing it?

#2 @desrosj
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

My interpretation of the request is either WordPress cleans up after all plugins when they are removed/uninstalled (which is impossible because WordPress will never know everything associated with every plugin), or an API that allows plugins to register data, tables, etc. that should be removed when the plugin is removed.

I am of the opinion that this is not something WordPress should handle, and it's the responsibility of each individual plugin.

Since this has not received any further feedback, I'm going to close this one out. If @cadentic2018 is able to provide clarification and it seems like something that is realistic and within the project's priorities, this can be reopened for exploration.

Note: See TracTickets for help on using tickets.