Make WordPress Core

Opened 3 years ago

Closed 14 months ago

Last modified 6 months ago

#54176 closed defect (bug) (invalid)

UI Defects - Featured Image

Reported by: cnaveenkumar's profile cnaveenkumar Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: Editor Keywords: has-patch needs-testing needs-design-feedback
Focuses: css Cc:

Description

Hi Team,

I see a UI bug when uploading an svg image as a featured image. (includes a screenshot for reference. )

https://i.ibb.co/rp03DHj/ui-issue.png

Change History (5)

#1 @sabernhardt
3 years ago

  • Component changed from General to Editor
  • Focuses css added

Welcome to Trac and thanks for the report!

An SVG does not display well there with the absolute positioning.

The Safe SVG plugin fixes that with:

img.components-responsive-wrapper__content[src$=".svg"] {
    position: relative;
}

#2 @hilayt24
3 years ago

.editor-post-featured-image__container .editor-post-featured-image__preview .components-responsive-wrapper span {
	padding-bottom: 0 !important;
}

.editor-post-featured-image__container .editor-post-featured-image__preview .components-responsive-wrapper .components-responsive-wrapper__content{
	position: static !important;
}

This will override the stylings that result in the error. And it solves the issue. Padding is also be removed from the span tag as its inline padding effects the images in twenty-twenty-one theme
Result of changes: https://www.awesomescreenshot.com/image/13965113?key=0689b1139b50a2c8bc1c573368dc2179

Last edited 3 years ago by hilayt24 (previous) (diff)

#3 @hilayt24
3 years ago

  • Keywords has-patch needs-testing needs-design-feedback added

#4 @mehdi01
14 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hello @cnaveenkumar Thanks for your report.

I was just checking is the problem is solved or not, in the mean time I just got another problem. When I tried to upload a SVG file as Featured Image, It's shows that it's not supported file type.

https://www.linkpicture.com/q/Screenshot-2023-05-20-at-12.48.01-PM.png (Attached the Screenshot)

#5 @swissspidy
6 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.