Make WordPress Core

Opened 8 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#54575 closed defect (bug) (fixed)

Provide guidance to users seeking to preview block themes on WordPress versions below 5.9

Reported by: kjellr Owned by:
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Themes Keywords:
Focuses: Cc:

Description

As per the changes in https://core.trac.wordpress.org/ticket/53410, If you're using WordPress >5.9 without the Gutenberg plugin installed, you'll see this message when you attempt to activate a block theme:

https://cldup.com/dWofSu5zN7.png

However, if you choose to "Live preview" the theme, you'll see an empty customizer:

https://cldup.com/XKwSLF1f6z.png

WordPress should show a similar message in this context as well. There's no reason to preview the theme if your install can't display or activate it.

Change History (13)

#1 @joyously
8 weeks ago

Related: #54549
It seems like the minimum WP version check would be limiting the themes.

#2 @hellofromTonya
8 weeks ago

  • Keywords needs-patch added

Test Report

Env:

  • WordPress: trunk (i.e. 5.9.0-beta-xxx)
  • Localhost: wp-env
  • OS: macOS
  • Theme: switch between TT1 and TT2
  • Plugins: none activated

Steps to Reproduce:

  1. Go to Appearance > Themes
  2. Activate Twenty Twenty-One (TT1) or older theme
  3. Scroll down to the Twenty Twenty-Two (TT2) theme
  4. Click on the "Live Preview" button

Expected behavior: Should open the site editor

Test Results:

The error notice appears:

The theme you are currently using is not compatible with Full Site Editing.

Can reproduce the issue.

Notes:

#3 @hellofromTonya
8 weeks ago

#54578 was marked as a duplicate.

This ticket was mentioned in Slack in #core-themes by kjell. View the logs.


7 weeks ago

This ticket was mentioned in Slack in #core-test by hellofromtonya. View the logs.


7 weeks ago

This ticket was mentioned in Slack in #core-themes by jffng. View the logs.


7 weeks ago

#7 @kafleg
7 weeks ago

Tested this in various ways. See the discussion and findings in #core-test.

#8 @paaljoachim
7 weeks ago

Having it open in an older version of WordPress might break the theme in various ways. As TT2 is very closely build alongside WP 5.9.

It would be better to have a notification in the preview saying that TT2 only works with WP 5.9 and newer and is not compatible with older WordPress versions. Mentioning that the site needs to be upgraded to be able to use the new default theme Twenty Twenty Two.

Last edited 7 weeks ago by paaljoachim (previous) (diff)

#9 @poena
7 weeks ago

Just noting that when Gutenberg is active, block themes still work on lower versions than 5.9. Gutenberg currently requires WordPress 5.7.

#10 @hellofromTonya
6 weeks ago

  • Component changed from General to Themes

@antonvlasenko do you have time to look at a patch for this?

#11 @antonvlasenko
6 weeks ago

@hellofromTonya I can't reproduce it using these steps.
I think we don't display Live Preview buttons for block themes now (because they cannot be live previewed neither in the Customiser nor in the Site Editor). Only the current theme can be previewed in the Site Editor (if it's a block theme).
https://cldup.com/G9q_VLKtzV.png
And when we merge this PR in the issue will be solved for Customiser as well.
https://cldup.com/Aj90405oKX.png
https://cldup.com/UU5fzA4ily.png
Please correct me if I'm wrong.

Last edited 6 weeks ago by antonvlasenko (previous) (diff)

#12 @hellofromTonya
6 weeks ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

I can confirm the "Live Preview" button was removed in #54460 / [52279] and #54549 / [52371] as the Site Editor does not (currently) have a "previewer" feature for non-activated block themes and block-themes do not support Customizer. The error message reported in this ticket no longer happens.

If the goal of this ticket is to have a previewer, then open an issue in Gutenberg's repo to request that feature be added.

#13 @antonvlasenko
6 weeks ago

Just FYI: there is already an issue in Gutenberg's repository that requests this feature (to have a previewer for block themes).

Note: See TracTickets for help on using tickets.