Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#54620 closed defect (bug) (invalid)

Customizer settings enabled and not working with Twenty Twenty Two theme

Reported by: kafleg's profile kafleg Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Customize Keywords: reporter-feedback
Focuses: Cc:

Description

  • WordPress version: 5.9 Beta 2
  • Theme: Twenty Twenty-Two

Twenty Twenty-Two theme is activated and there is no Customize option inside Appearance > Customize.

But, I added a plugin that add a section/setting in the customizer.

Now, I can see Appearance > Customize.

If I go through the Site Identity, the Site Tagline option is not working. It means nothing got changed in the front end.

Also, the use of the Menu option is not working.

Change History (10)

#1 @kafleg
2 years ago

There is same issue with beta 3 as well.

#2 @kafleg
2 years ago

There is same issue with beta 4 as well.

#3 @dlh
2 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Thanks for the report, @kafleg. We're tracking this issue in #54683, which had a fix committed three days ago.

#4 @kafleg
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hello @dlh
I don't think the issue that I have created is not the same issue that you have mentioned.

Still, the issue remains in RC2.

#5 @dlh
2 years ago

  • Keywords reporter-feedback added

Apologies, @kafleg, you're correct. I misunderstood the description of the issue.

Still, I can't seem to replicate it. The tagline updates as expected, as does the nav menu as long as it's rendered with wp_nav_menu().

Someone can correct me if I'm wrong about this, but I don't think navigation blocks are intended to work in the Customizer as they aren't "nav menus" in the way the Customizer understands them.

#6 @dlh
2 years ago

Oops, I forgot to actually ask for feedback: Can you provide steps or sample code to replicate the issue?

#7 @kafleg
2 years ago

@dlh
There is no customizer if we have block themes activated. But if you install any plugin that uses customizer settings, then we will have customizer in Appearance > Customize. In the customizer, there is not only plugin settings but Site identity, Menus, Additional CSS section will be enabled automatically. Additional CSS section will work, however, Tagline and Menu won't work with the activated block theme.

Thank you

#8 @dlh
2 years ago

Thanks @kafleg. The testing referenced in comment:5 was conducted against Twenty Twenty-Two with a plugin that hooks into customize_register. I've tested again and still find that the site tagline (added via a block in the site editor) and nav menus (rendered via wp_nav_menu()) still update as expected in the Customizer.

#9 follow-up: @tinomueller
2 years ago

I have installed clean 5.9-RC2-52579 - Twenty Twenty-Two, when clicking on Customizer it opens site-editor.php instead of customizer.php .

#10 in reply to: ↑ 9 @desrosj
22 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to tinomueller:

I have installed clean 5.9-RC2-52579 - Twenty Twenty-Two, when clicking on Customizer it opens site-editor.php instead of customizer.php .

Opening the Site Editor instead of the Customizer when a block theme is activated is the intended behavior.

I've done some more testing and I'm unable to reproduce the original issue as described.

If this is still happening on a fresh install using the latest version of WordPress (currently 6.0) please reopen with detailed steps someone can take to reproduce the problem.

Note: See TracTickets for help on using tickets.