Make WordPress Core

Opened 2 years ago

Closed 4 weeks ago

#55324 closed defect (bug) (worksforme)

Twenty Twenty: Scroll to top not working

Reported by: presskopp's profile Presskopp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: Cc:

Description

For whatever reason, in my installation the scroll to top arrow doesn't work. I changed

<a class="to-the-top" href="#site-header">

to

<a class="to-the-top" href="#">

and it was working again. Maybe worth patching?

Another alternative would be

<a class="to-the-top" href="#top">

Change History (7)

#1 @sabernhardt
2 years ago

  • Keywords reporter-feedback added

The header element has id="site-header" in Twenty Twenty's header.php.

Does a plugin (or child theme) change that ID?

#2 @Presskopp
2 years ago

It has the ID, but - don't ask me why - it's not working as is

#3 @sabernhardt
2 years ago

  1. Which browser(s) and operating system do you use when it does not work?
  2. If you look at the browser console, does it show any errors? (this might relate to the JavaScript scroll effect)

#4 @Presskopp
22 months ago

I'm sorry I forgot which installation it was so I can't tell.

#5 @karmatosed
4 weeks ago

  • Keywords close added

@Presskopp it seems you are confirming that you can't reproduce this now? As that seems correct, I am going to be adding the close keyword so we can progress this ticket.

However, should you still be able to reproduce we can remove that keyword and review again. Thank you for collaborating so far.

#6 @Presskopp
4 weeks ago

You're right. I am not able to reproduce anymore. I tested right now using different browsers (Firefox, Opera, Chrome, Edge, Falkon) and it was working well. Sorry I can't remember what I did 2 years ago.

#7 @karmatosed
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thank you @Presskopp I am going to therefore close this ticket. If you do reproduce please create a new ticket.

Note: See TracTickets for help on using tickets.