Make WordPress Core

Opened 2 years ago

Closed 18 months ago

Last modified 10 months ago

#55771 closed enhancement (maybelater)

Add oEmbed support for Looker Studio

Reported by: swissspidy's profile swissspidy Owned by: helen's profile helen
Milestone: Priority: normal
Severity: normal Version:
Component: Embeds Keywords: has-screenshots
Focuses: Cc:

Description

Google Data Studio has an oEmbed API, although not a well documented one.

Documentation: https://developers.google.com/datastudio/share/embed#embed_using_oembed

Example report: https://datastudio.google.com/c/u/0/reporting/1se-9ZRSukdgQUiRqYTSjT8nFLTV0v8Uq/page/y5MR

Endpoint: https://datastudio.google.com/oembed?url=<url>

Example response:

{
  "type": "rich",
  "version": "1.0",
  "provider_name": "Google Data Studio",
  "provider_url": "https:\/\/datastudio.google.com",
  "html": "<iframe width=\"600\" height=\"955\" src=\"https:\/\/datastudio.google.com\/embed\/reporting\/1se-9ZRSukdgQUiRqYTSjT8nFLTV0v8Uq\/page\/y5MR?feature=oembed\"  frameborder=\"0\" style=\"border:0\" allowfullscreen><\/iframe>",
  "width": "600",
  "height": "955",
  "thumbnail_url": "https:\/\/datastudio.google.com\/c\/u\/0\/reporting\/1se-9ZRSukdgQUiRqYTSjT8nFLTV0v8Uq\/page\/y5MR\/thumbnail?sz=w600-h920-p-nu&feature=oembed",
  "thumbnail_width": "600",
  "thumbnail_height": "920",
  "title": "[Data Studio Community Connector Showcase] Aggregate information across multiple sources"
}

Is the service is popular enough for core developers to have heard of it before? Is it “mainstream?”

I'd say so, yes. This service is quite big and has been around for many years.

If similar services are already supported, how does this service compare in terms of size, features, and backing?

I don't think there's a similar service already supported, but haven't checked closely.

Does this service have a large following on Twitter, Facebook, or other social media? Is its Twitter account verified?

It does not have a dedicated Twitter account.

Is its oEmbed endpoint clearly established and properly documented? (Sometimes, they are just a developer’s pet project that may not be supported.)

Documentation could be better, but I think that's a known thing.

Does the oEmbed endpoint work with WordPress’ oEmbed auto-discovery? If not, could it be made to work with additional HTML tags or attributes being added to the allow-list?

It does not, simply because Data Studio reports don't contain the necessary HTML tags for auto discovery to work.

Does the service make an effort to build relationships with developers, such as through robust APIs?

A robust API has been available for a while, see https://developers.google.com/datastudio/api

How old is the service?

6 years (since 2016)

Does it have a well-established Wikipedia article? (Seriously.)

Yes, see https://en.wikipedia.org/wiki/Google_Data_Studio

Has anyone written a WordPress plugin that leverages the service in some way, whether adding it as an oEmbed provider, creating a shortcode, or leveraging other APIs of the service? Do these plugins have any noticeable adoption or traction that would indicate usage and demand?

I could only find https://wordpress.org/plugins/embed-google-data-studio/, which is a very new plugin and thus does not have noticeable adoption yet.

Is the provider frequently proposed?

I think this is the first time.

Change History (13)

#1 @audrasjb
20 months ago

  • Keywords needs-screenshots needs-patch added

Thank for proposing this. Sounds good to me. Could someone share a screenshot of what it would looks like once embedded in a WordPress website?

This ticket was mentioned in PR #3227 on WordPress/wordpress-develop by swissspidy.


19 months ago
#2

  • Keywords has-patch added; needs-patch removed

Adds oEmbed support for Google Data Studio.

Trac ticket: [](https://core.trac.wordpress.org/ticket/55771)

#3 @swissspidy
19 months ago

  • Keywords has-screenshots added; needs-screenshots removed
  • Milestone changed from Awaiting Review to Future Release

Uploaded screenshots to https://imgur.com/a/30rWpj5 and also the attached pull request.

#4 @jorbin
19 months ago

  • Keywords commit added
  • Milestone changed from Future Release to 6.1

LGTM

#5 @helen
19 months ago

  • Owner set to helen
  • Resolution set to fixed
  • Status changed from new to closed

In 54129:

Embeds: Add Google Data Studio as a trusted oEmbed provider

Props swissspidy
Fixes #55771

#7 @audrasjb
19 months ago

  • Keywords add-to-field-guide needs-user-docs added; commit removed

#8 @peterwilsoncc
18 months ago

  • Keywords has-patch removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

While looking through new providers for 6.1, I've noticed a couple of things:

I can't see oembed meta tags for alternatives per the oembed.com spec in any of the URLs. I've viewed the source of:

  • the user editing URL https://datastudio.google.com/u/0/reporting/1Lkg3k30dv3POg80rm3sQk06BVi9hqVES/page/1M
  • the sharing URL: https://datastudio.google.com/reporting/1Lkg3k30dv3POg80rm3sQk06BVi9hqVES/page/1M?s=iizT7ImiDGA
  • the embed URL: https://datastudio.google.com/embed/reporting/1Lkg3k30dv3POg80rm3sQk06BVi9hqVES/page/1M

(These links are all for the sample report on the embed docs)


If I am mistaken about the missing meta tags then I think the URL structure is incorrect in [54129].

The /u/0/ suggests a user editing URL and will only work with a users first sign-in. It won't work with second or subsequent sign-ins as the URL will contain /u/1/ ... /u/N/. The current regex doesn't allow for these logins

During a quick test, a share link is in the format https://datastudio.google.com/s/.+ although selecting to embed the demo from the documentation shows the URL https://datastudio.google.com/embed/reporting/1Lkg3k30dv3POg80rm3sQk06BVi9hqVES/page/1M


I'm going to reopen this for now so the service can be confirmed as spec complient and the URL format verified.

#9 @desrosj
18 months ago

  • Keywords dev-feedback added

#10 @peterwilsoncc
18 months ago

@helen @swissspidy Having considered this overnight, I think it needs to be reverted as the provider standards require support of the oembed spec. Without the meta tags, datastudio does not qualify.

#11 @peterwilsoncc
18 months ago

In 54465:

Embeds: Revert Google Data Studio as trusted provider.

Remove Google Data Studio's status as a trusted oEmbed provider pending upstream implementation of the oEmbed specification.

See #55771.

#12 @peterwilsoncc
18 months ago

  • Keywords add-to-field-guide needs-user-docs dev-feedback removed
  • Milestone 6.1 deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed

#13 @swissspidy
10 months ago

  • Summary changed from Add oEmbed support for Google Data Studio to Add oEmbed support for Looker Studio
Note: See TracTickets for help on using tickets.