Make WordPress Core

Opened 2 years ago

Last modified 2 years ago

#55875 new enhancement

"Add New" plugin should be "Add Plugin" because it now allows updating an existing plugin as well

Reported by: _smartik_'s profile _smartik_ Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: ui, administration Cc:


"Add New" plugin should be called something else than "new" because it allows updating an existing plugin as well.

Sometimes I'm using the "Add New" plugin to upload an update of a plugin that is already installed. But it does not make sense because I don't add a new plugin. Instead, I update it.

So the sidebar and the top button should be renamed to something else.
Maybe "Add plugin" would be more accurate.

Change History (2)

#1 @SergeyBiryukov
2 years ago

Hi there, welcome back to WordPress Trac! Thanks for the ticket.

Something to consider when looking into this is that the "Add New" string is used in the admin menu for most of the WordPress entities and data types:

_x( 'Add New', 'file' )
_x( 'Add New', 'link' )
_x( 'Add New', 'post' )
_x( 'Add New', 'page' )
_x( 'Add New', 'plugin' )
_x( 'Add New', 'site' )
_x( 'Add New', 'theme' )
_x( 'Add New', 'user' )

There are also a few more strings, which are not displayed in the admin menu by default as far as I can tell, but follow the same pattern:

_x( 'Add New', 'add new media' )
_x( 'Add New', 'Customize Changeset' )
_x( 'Add New', 'Reusable block' )
_x( 'Add New', 'Template' )
_x( 'Add New', 'Template Part' )
_x( 'Add New', 'Navigation Menu' )

So it seems like changing _x( 'Add New', 'plugin' ) to something else would make it inconsistent with the other admin menu items.

Note: See TracTickets for help on using tickets.