Make WordPress Core

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#56324 closed defect (bug) (fixed)

Improve the description of param `$list ` in `wp_list_sort()` docblock

Reported by: audrasjb's profile audrasjb Owned by: audrasjb's profile audrasjb
Milestone: 6.1 Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch commit
Focuses: docs Cc:

Description

This issue was reported by @rherault on DevHub User Contributed notes.

In the documentation, the first parameter :
(array) (Required) An array of objects to sort.
can be :
(array) (Required) An array of objects or array to sort.

because this parameter accepts both array of array and array of objects.

https://developer.wordpress.org/reference/functions/wp_list_sort/

Change History (7)

This ticket was mentioned in PR #3053 on WordPress/wordpress-develop by audrasjb.


22 months ago
#1

  • Keywords has-patch added; needs-patch removed

#2 @audrasjb
22 months ago

  • Keywords commit added

#3 @audrasjb
22 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 53811:

Docs: Improve the description of param $list in wp_list_sort() docblock.

Props audrasjb, rherault.
Fixes #56324.
See #55646.

This ticket was mentioned in Slack in #docs by audrasjb. View the logs.


22 months ago

#5 @rherault
22 months ago

Thanks a lot for this PR @audrasjb ! :)

#6 @audrasjb
22 months ago

Thank you @rherault for reporting this issue on Devhub. I didn't approve your comment since the issue is resolved (or rather will be resolved in WP 6.1) but in exchange, you just made your very first contribution to WordPress Core ✌️

mukeshpanchal27 commented on PR #3053:


22 months ago
#7

@audrasjb Can you please close this PR as you already merged it https://core.trac.wordpress.org/changeset/53811

Note: See TracTickets for help on using tickets.