Make WordPress Core

#56937 closed defect (bug) (duplicate)

Paginated results of a 'feed' term inaccessible

Reported by: dd32's profile dd32 Owned by:
Milestone: Priority: low
Severity: normal Version: 2.7.1
Component: Canonical Keywords:
Focuses: Cc:

Description

As reported by @alvarogois in #meta6531, if a taxonomy (core, or custom) includes a term 'feed' and you attempt to access the paginated results of it, you'll be redirected to the incorrect location by redirect_canonical().

The cause is due to this code:
https://core.trac.wordpress.org/browser/trunk/src/wp-includes/canonical.php?rev=53043&marks=430,437,443#L427
(is_paged() = true, /feed exists within path, strip it off)

For example, in the above Meta ticket, https://wordpress.org/plugins/tags/page/2/ is incorrectly redirected to https://wordpress.org/plugins/tags/page/2/, from there custom WordPress.org code kicks in and redirects it elsewhere.

This likely traces back to [10505] / #8642.

Change History (1)

#1 @dd32
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #46061.

Note: See TracTickets for help on using tickets.