Make WordPress Core

#57869 closed defect (bug) (worksforme)

Media Library: Insert URL

Reported by: medievaldragon's profile Medievaldragon Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1.1
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

Note: I posted this in the support forum. @threadi recommended me to post it here. I'm not familiar with this forum, so apologies if some of the options are wrong (i.e. workflow keyword).

The WordPress Media Library offers options to upload from computer or to drag and drop.

However, there is a feature that everyone in the community might appreciate: “Insert from URL.”

No. I don’t want to import images from an external website into my local wordpress upload folder. That could be an option, of course.

However, the feature I am requesting is the exact function of the IMAGE block.

The image block allows you to “Insert URL” and the view mode allows you to see the image in real time in your IMAGE block within the WordPress Editor.

https://i.imgur.com/YOVMK8S.jpg

I recently moved all of my images to a CDN. For those of us who use a CDN, sometimes we have the luxury to upload 10MB+ images. The least I would want is to import those into my WordPress upload folder.

Now if we could insert the CDN URL instead, and every time the image is loaded straight from the CDN, that allows for large images to load quick, and no downtime loading or stress on our wordpress hosting.

https://i.imgur.com/MuYE1l4.jpg

https://i.imgur.com/LBCiSJw.jpg

I assume as well an Insert URL should be added within the Gallery UI. Not sure how thumbnails would be handled, maybe resizing the same URL inserted, as the thumbnail wouldn’t be saved in the WordPress folder.

https://i.imgur.com/vPC7rE8.jpg

This could immensely help wordpress writers, and even plugin makers, as plugin makers wouldn’t need to add this feature themselves. Right now, I would love to purchase a plugin named Draw Attention, but because I have migrated all of my wordpress upload folder’s images to a CDN, the plugin is kinda useless to me, because it doesn’t have the Insert URL feature for me to add images from my CDN.

If WordPress provided the feature out of the box, then every plugin developer can have access to that feature.

Change History (3)

#1 @sarunraj
15 months ago

Env

  • WordPress 6.1.1
  • Chrome 110.0.5481.177
  • MacBook Air M1
  • Theme: Twenty Twenty Three
  • Gutenberg Editor
  • Plugin: WP Downgrade

It's not a bug, it's a feature request for adding Insert URL option to Gallery Blocks.

Last edited 15 months ago by sarunraj (previous) (diff)

This ticket was mentioned in Slack in #core-test by juhise. View the logs.


15 months ago

#3 @adamsilverstein
11 months ago

  • Keywords reporter-feedback added; changes-requested removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi @Medievaldragon -

I believe this issue was resolved over in Gutenberg, please see this issues/PR

https://github.com/WordPress/gutenberg/issues/10057 - External links in the Gallery block (was #5366) #10057

https://github.com/WordPress/gutenberg/pull/25940 - Gallery: Convert Gallery block to use Image blocks instead of having its own nested image format #25940

Now, the Gallery builds out using image blocks, so you should be able to insert from URL, although I'm not sure its possible from the first screen. Can you give it another test with new and existing galleries? (with the latest Gutenberg plugin active)

In any case, this issue would need to be raised in Gutenberg, so if you still are seeing a problem, can you please open a ticket there?

Closing this as "worksforme" because I'm not sure we still need to fix something in core. If I missed something, feel free to re-open.

Note: See TracTickets for help on using tickets.