Make WordPress Core

#58105 closed feature request (duplicate)

Separate language for the website and dashboard

Reported by: marc4's profile Marc4 Owned by: audrasjb's profile audrasjb
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: accessibility, administration Cc:

Description

Hello,

It would be interesting to be able to select a language for the dashboard and a different language for the website.

Many users write in WordPress in a language other than their native language. Not being able to select the separate language on the dashboard forces users to have to use the WordPress dashboard in the language other than their own.

I know there are options to achieve this, such as creating an admin user with the language the website is targeting and then creating another user and here selecting the user's native language. However this is not within the reach of every user. Maybe even some plugin will allow something similar, but I think this is a feature that should be part of WordPress core.

I attach a screenshot to show it graphically.

Thanks :)

Attachments (2)

separate-language.png (65.7 KB) - added by Marc4 13 months ago.
languageselection.png (17.6 KB) - added by Otto42 13 months ago.
Language selection already exists on the user's profile.

Download all attachments as: .zip

Change History (18)

#1 follow-up: @audrasjb
13 months ago

  • Keywords changes-requested removed
  • Owner set to audrasjb
  • Status changed from new to assigned
  • Version 6.2 deleted

Hello and welcome to WordPress Trac @Marc4,

I agree that this feature would be welcome and I think adding an option for this sounds relevant. Pinging @SergeyBiryukov and @ocean90: do we have an existing ticket for this feature request? I couldn't find anything but I guess it was already discussed before…

Last edited 13 months ago by audrasjb (previous) (diff)

#2 @NekoJonez
13 months ago

Isnt this feature request to implement this plugin into core?

https://wordpress.org/plugins/preferred-languages/

Which personally would get a +1 from me. Since its a plugin I always install.

Now, in rare cases... I have this plugin not translating the admin bar. So, if we would "copy over" this plugin into core, we need to test this with a lot of different situations.

Also, just thinking out loud... How hardcoded is the getting of languages? Since if it always gets the site language, we might have to rewrite or add the loading of the correct language file into a lot of files or am I wrong?

This ticket was mentioned in Slack in #meta by nekojonez. View the logs.


13 months ago

#5 @Otto42
13 months ago

I'm confused. Isn't this already in core? You can select your language on the users->your profile section, and it switches the dashboard to that language. It doesn't affect the site language (front end) at all.

I frequently use this myself on Rosetta sites, because often I do not know the language that the site is in, but I can switch to dashboard to English for me just fine.

#6 @audrasjb
13 months ago

I think what is proposed is slightly different from what already exists: the idea is to separate the locale used in the admin from the language used on front-end (= printed in the lang attribute of the <html> tag).

#7 @Otto42
13 months ago

Yes, but the user's selection does that. You can change it per user on the Users-your profile area and it is changing the language for the dashboard only.

Admittedly, there is not a site wide way to do it for all users, but since you can do it per user, then it doesn't really make any sense to have it a site wide way. One would think the user setting overrides that.

@Otto42
13 months ago

Language selection already exists on the user's profile.

#8 @audrasjb
13 months ago

Yes, but the locale of the website admins doesn't necessarily matches the website's locale. And even if each logged-in user can manage their locale in their profile, the default locale will still be the default locale of the admin… which is not necessarily the website's locale (printed on front-end).

It would be nice to be able to separate the default locale of the WordPress admin from the locale used in front-end.

Last edited 13 months ago by audrasjb (previous) (diff)

#9 @NekoJonez
13 months ago

It may be a good idea to add something with that setting explaining what it does. Like "In this language your dashboard will be displayed" or something.

#10 in reply to: ↑ 1 @SergeyBiryukov
13 months ago

Replying to audrasjb:

do we have an existing ticket for this feature request?

Appears to be a duplicate of #49971.

#11 @Otto42
13 months ago

So basically, you want to separate the front end from the back end, and have the back end selection be the "site default". You would also need the back end selection to be defaulting to the same as the front end selection.

I mean, yes, you can do it. I just don't see a lot of value in it. I think perhaps this request came from somebody who didn't know that the user's profile language selection exists. Perhaps explanation or possibly linking to the user profile from the site language selection is a better idea.

#12 @audrasjb
13 months ago

I think we probably need a new Site language setting, separated from Admin default language :)

#13 @Marc4
13 months ago

Thank you all for your comments :)

The idea is that you can select a language for the back end and a different one for the front end.

As @audrasjb says, now, when you select spanish in the back end, some texts of the web change from english to spanish, independently of the theme you use, like for example the date texts, created by, the texts of the comments interface, etc. Also the "lang" tag in the header changes from <html lang="en"> to <html lang="es"> indicating a different language to browsers, indexing robots, etc.

This could all be solved by offering language separation for the back-end and front-end, so that users could use the back-end in their native/preferred language without affecting the front-end.

Now someone with no WordPress experience can change the language on the back-end without inferring that it will also change the language on the front-end, and that's a problem.

I think being able to have different languages on the back-end and front-end is a logical feature for both new and experienced users.

#14 follow-up: @audrasjb
13 months ago

I second this proposal, being able to set up different languages on the back-end and front-end is a useful feature.

#15 follow-up: @NekoJonez
13 months ago

This is something that the preffered languages plugin can do. Besides you being able to set fallback locales for the site language, in the user settings you can change the dashboard language... Its like @Otto42's screenshots, that location.

Now, I dont know exactly what it does with <html lang> tbh.

#16 in reply to: ↑ 14 @SergeyBiryukov
13 months ago

Replying to audrasjb:

I second this proposal, being able to set up different languages on the back-end and front-end is a useful feature.

Unless I'm missing something, as noted in comment:10, this seems pretty much the same as what #49971 suggests. Should we close one or the other to keep the discussion in one place? :)

#17 in reply to: ↑ 15 @audrasjb
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Replying to NekoJonez:

Now, I dont know exactly what it does with <html lang> tbh.

That's the point, the Preferred Language feature plugin doesn't handle this.

But yeah @SergeyBiryukov is right, this is a duplicate of #49971.

Note: See TracTickets for help on using tickets.