Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 3 months ago

#58184 closed defect (bug) (duplicate)

WordPress database error Illegal mix of collations

Reported by: varinupadhyay's profile varinupadhyay Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1.1
Component: Database Keywords:
Focuses: Cc:

Description

Please see attached error log file.

The spam is trying to run WordPress db query. Please check the last line of error log.

"made by require('wp-blog-header.php'), wp, WP->main, WP->query_posts, WP_Query->query, WP_Query->get_posts"

Inside wp->main() /src/public/wp-includes/class-wp.php line 777, WordPress run parse_query() function which should strip out all the garbage input. But it is not.

Can you please look into this asap? Also, please suggest a filter for parse_request filter which stop these bogus queries.

Thank you

Attachments (1)

error_log.png (138.4 KB) - added by varinupadhyay 12 months ago.
Error Log

Download all attachments as: .zip

Change History (3)

@varinupadhyay
12 months ago

Error Log

#1 @Presskopp
12 months ago

  • Component changed from Posts, Post Types to Database
  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Severity changed from blocker to normal
  • Status changed from new to closed

Duplicate of #58133.

Please don't spam trac

#2 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.