WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#5852 closed enhancement (duplicate)

Search Widget Does Not Check for searchform.php

Reported by: Ruxton Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch
Focuses: Cc:

Description

The search widget contained in widgets.php does not first check for the TEMPLATEPATH.'/searchform.php' prior to outputting it's own specific search form.

I consider this to be a major fallback of the search widget, i understand it must provide it's own form. But it should check for the templates search form and if it's there, use that, otherwise fall back to using what is already in the widget.

Attachments (1)

5852_widgets.php.diff (985 bytes) - added by AndrewFrazier 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 @AndrewFrazier8 years ago

  • Keywords has-patch added; searchform search widget removed

This has caught me out before. Here's a patch.

comment:2 @Ruxton8 years ago

nice work andrew, i had intended to file a patch this weekend, came here to do it and you'd already taken care of ti, thanks :)

comment:3 @Otto427 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #5567

comment:4 @Otto427 years ago

  • Milestone 2.6 deleted
  • Version 2.3.3 deleted
Note: See TracTickets for help on using tickets.