Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#58529 closed feature request (duplicate)

Make / plugin API for closed plugins that are no longer available

Reported by: ramon-fincken's profile ramon fincken Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: administration Cc:

Description

when we visit for instance https://wordpress.org/plugins/delete-all-comments/#description

It will tell you this "This plugin has been closed and is no longer available for download."

However ..
visiting the wordpress.org API -> https://api.wordpress.org/plugins/info/1.0/delete-all-comments/

shows
"Plugin not found."

Why not
1) at least show a message here that is the same as on the plugin website ?
-> Task for Make
2) also show this in WP->tools and/or WP->plugins and/or WP->dashboard
-> Task for Core (plugins/API).

Because .. right now , if you have such a plugin installed, and you do not visit the wordpress.org page for that plugin. You have *no* knowledge of this data/info at all.

Change History (4)

#1 @audrasjb
12 months ago

  • Keywords needs-patch changes-requested needs-unit-tests needs-testing removed
  • Version trunk deleted

Hello and thanks for the ticket.

This is already discussed in #30465.
As this cannot be fixed on Core side (changes on .org APIs belong to .org, not Core), I'd recommend opening a ticket on Meta Trac: https://meta.trac.wordpress.org

#3 @NekoJonez
12 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Since there is now a WP Meta trac ticket and this is essentially a duplicate of #30465... and to keep the discussion in one place, let's close this one and let's keep it in that ticket. :)

#4 @swissspidy
12 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.